查找左边界

Alice is providing print service, while the pricing doesn’t seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It’s easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.

Input

The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , …, s n, p n (0=s 1 < s 2 < … < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ … ≥ p n ≥ 0)… The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1…n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 … q m (0 ≤ q i ≤ 10 9 ) are the queries.

Output

For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.

Sample Input

1
2 3
0 20 100 10
0 99 100

Sample Output

0
1000
1000

解题思路

思路:可以从后往前做一个O(n)的预处理,表示需要的纸张少于si时,多打印纸需要的最小花费。从后往前,则min[ si ] = min ( si*pi , min[ si+1 ] ),之后每次查询只需比较min[si]和正常方法的话费取最小即可。

因为输出量较大 10^6 用cout果断T了,需要用printf

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define LL long long
const LL inf = 1e18;
LL s[100005],q;
LL p[100005];
LL ss[100005];
LL n,m;
LL A(LL x)
{
    int l=0,r=n,mid;
    while(r-l>1)
    {
        mid=(l+r)>>1;
        if(s[mid]<=x)
            l=mid;
        else
            r=mid;

    }
    return l;
}

int main()
{ //freopen("E:\\in.txt","r",stdin);
    int T;
    scanf("%d",&T);
    LL sum;
    while(T--)
    {

        sum = 0;
        scanf("%lld%lld",&n,&m);
        for(int i = 0 ; i < n ; i++)
        scanf("%lld%lld",&s[i],&p[i]);
        LL mif =inf;
        for(int i = n-1 ; i >= 0  ; i--)
        {
            mif = min(mif,s[i]*p[i]);
            ss[i] = mif;
        }

        for(int i = 0 ; i < m ; i++)
        {
            scanf("%lld",&q);
            if(q>=s[n-1])
            printf("%lld\n",q*p[n-1]);
            else
            {
                int k = A(q);
                LL sum3,sum2;

                    sum2 = q*p[k];
                    
                    LL t = min(sum2,ss[k+1]);
                    printf("%lld\n",t);

            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值