PAT甲级 1140 Look-and-say Sequence (20 分)

Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, …
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:
Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:
Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8

Sample Output:
1123123111


题目大意:
解释D, D1, D111, D113, D11231, D112213111

  1. D
  2. 对于D,D出现1次 -> D1
  3. 对于D1,D出现1次,1出现1次 -> D111
  4. 对于D111,D出现1次,1出现3次 -> D113
  5. 对于D113,D出现1次,1出现2次,3出现1次 -> D11231
  6. 对于D11231,D出现1次,1出现2次,2出现1次,3出现1次,1出现1次 -> D112213111

题目给出D、N,求对于以D开头的序列的第N个数

样例:D=1,N=8
1
11
12
1121
122111
112213
12221131
1123123111

分析:
这道题很多地方都出现过了,Leetcode、蓝桥杯都做过,是个挺好的字符串模拟题


#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    // freopen("/Users/zhbink/Documents/C++/C++/in.txt","r",stdin);
    string d;
    int n;
    cin >> d >> n;
    while (-- n)
    {
        int pos = 0;
        string nxtd;
        while (pos != d.length())
        {
            char c = d[pos];
            int len = 1;
            while (d[++pos] == c)
                len ++;
            nxtd += c + to_string(len);
            
        }
        d = nxtd;
    }
    cout << d << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值