Matrix

		
Description
There is a matrix    that has    rows and    columns   .Then we perform   operations:  

1 x y: Swap row x and row y   ;  

2 x y: Swap column x and column y   ;  

3 x y: Add y to all elements in row x   ;  

4 x y: Add y to all elements in column x   ;

Input

There are multiple test cases. The first line of input contains an integer    indicating the number of test cases. For each test case:  

The first line contains three integers   ,    and   .  
The following    lines describe the matrix M.  for all   .  
The following    lines contains three integers   ,    and   .  

Output

For each test case, output the matrix    after all    operations.

Sample Input

2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2

Sample Output

12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1

 

题目很容易看懂:有4种操作,

1:交换a行和b行的数,

2:交换a列和b列的数,

3;给a行每个数都加上b,

4:给a列每个数都加上b;
思路:可以给每行和每列都增加一个数组,方便去交换每行每列的数,还要在增加radd[],cadd[]数组,去记录哪一行哪一列各增加了多少:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int row[1009],col[1009],map[1009][1009];
int radd[1009],cadd[1009];
int main()
{
	int t,n,m,k,q,x1,x2,y1,y2,i,j,op;
	int a,b;
	scanf("%d",&t);
	while(t--)
	{
		memset(radd,0,sizeof(radd));
		memset(cadd,0,sizeof(cadd));
		scanf("%d%d%d",&n,&m,&q);
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			scanf("%d",&map[i][j]);
		}
		for(i=1;i<=n;i++)
		row[i]=i;
		for(i=1;i<=m;i++)
		col[i]=i;
		for(i=0;i<q;i++)
		{
			scanf("%d%d%d",&op,&a,&b);
			if(op==1)
			swap(row[a],row[b]);
			else if(op==2)
			swap(col[a],col[b]);
			else if(op==3)
			radd[row[a]]+=b;
			else if(op==4)
			cadd[col[a]]+=b;
		}
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				if(j>1) printf(" ");
				printf("%d",map[row[i]][col[j]]+radd[row[i]]+cadd[col[j]]);
			}
			printf("\n");
		}
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值