杭电2054 A == B ?

看完题目后觉得题太简单了,给的测试案例也都是整数,许多情况根本考虑不到。主要是考虑小数中末尾的0,如9.0和9.00是相等的数,所以输入的数据类型最好定义成字符串,然后在比较两个数前先把末尾的0去掉。另外,在定义字符串是如果你用一个a[100]来输入交上去后也会报错,当你开到a[50000]时它才会让你AC!!

Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 Input
each test case contains two numbers A and B.
 Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 Sample Input
  
  
1 2 2 2 3 3 4 3
 Sample Output
  
  
NO YES YES NO

代码:

#include<iostream>
#include<cstring>
using namespace std;
void qq(char *a)
{
 int len,i;
 len=strlen(a)-1;
 for(i=len;i>=0;i--)
 {
  if(a[i]=='0')     
   len--;                             //去掉小数点后的0
  else
   break;
 }
 if(a[len]=='.')    //如果小数点后全是0,那小数点也得去掉
  len--;
 a[len+1]='\0';     //通过加结束标志来去掉
}
int main()
{
 int i,len;
 char a[50000],b[50000];
 while(cin>>a>>b)
 {
  len=strlen(a);
  for(i=0;i<len;i++)
  {
   if(a[i]=='.')    //对有小数点的数据处理
    qq(a);
   

  }
  len=strlen(b);
  for(i=0;i<len;i++)
  {
   if(b[i]=='.')
    qq(b);
   
  }
  if(strcmp(a,b))
   cout<<"NO"<<endl;
  else
   cout<<"YES"<<endl;
 }
 return 0;
}

 

 

 

  • 8
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值