POJ 3295 Tautology

4 篇文章 0 订阅


Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8983 Accepted: 3435

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

Source



题意:问对于输入的由最多五个布尔变量组成的逻辑表达式,问是否为用真式。

思路:直接枚举每个变量的值,然后判断是否用真。因为是前缀表达式,直接从后往前扫描计算即可,借用一个栈。



#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <queue>
#include <set>

using namespace std;

//#define WIN
#ifdef WIN
typedef __int64 LL;
#define iform "%I64d"
#define oform "%I64d\n"
#else
typedef long long LL;
#define iform "%lld"
#define oform "%lld\n"
#endif

#define S64I(a) scanf(iform, &(a))
#define P64I(a) printf(oform, (a))
#define FOR(i, s, t) for(int (i)=(s); (i)<(t); (i)++)

const int INF = 0x3f3f3f3f;
const double eps = 10e-9;
const double PI = (4.0*atan(1.0));

const int maxn = 1000 + 20;
char s[maxn];
bool sstack[maxn];
int sstackcnt;
int idx(char c) {
	if(c == 'p') return 0;
	if(c == 'q') return 1;
	if(c == 'r') return 2;
	if(c == 's') return 3;
	if(c == 't') return 4;
}

void push(bool c) {
	sstack[sstackcnt++] = c;
}

bool pop() {
	bool res = sstack[--sstackcnt];
	return res;
}

int main() {
	while(scanf("%s", s)!=EOF && strcmp("0", s)) {
		int ans = 1;
		int len = strlen(s);
		bool t;
		for(int ii=0; ii<(1<<6); ii++) {
			sstackcnt = 0;
			int i=len-1;
			while(i>=0) {
				char tc = s[i];
				bool tt1, tt2;
				switch(tc) {
					case 'K':
						tt1 = pop();
						tt2 = pop();
						t = tt1 && tt2;
						break;
					case 'A':
						tt1 = pop();
						tt2 = pop();
						t = tt1 || tt2;
						break;
					case 'N':
						tt1 = pop();
						t = 1^tt1;
						break;
					case 'C':
						tt1 = pop();
						tt2 = pop();
						t = (1^tt1) || tt2;
						break;
					case 'E':
						tt1 = pop();
						tt2 = pop();
						t = tt1==tt2;
						break;
					default :
						t = (ii & (1<<idx(tc))) ? 1 : 0;
				}
				push(t);
				i--;
			}
			t = pop();
			if(t==0) {
				ans = 0;
				break;
			}
		}
		if(ans) {
			puts("tautology");
		} else {
			puts("not");
		}
	}

	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值