poj 3295 Tautology

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10430 Accepted: 3961

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not
/*
英语太渣,在万能的标哥的帮助下用了一天才能懂,说多了都是泪啊,脑残的孩子慢慢学吧
*/
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <string>

using namespace std;

int Arr[6];
stack<int >a;
string str;

void Bit(int n)
{
    int top = 0;
    memset(Arr,0,sizeof(Arr));
    while(n)
    {
        Arr[top++] = n%2;
        n/=2;
    }
}

bool Judge(char s)
{
    switch(s)
    {
    case 'p':
        a.push(Arr[0]);
        break;
    case 'q':
        a.push(Arr[1]);
        break;
    case 'r':
        a.push(Arr[2]);
        break;
    case 't':
        a.push(Arr[3]);
        break;
    case 's':
        a.push(Arr[4]);
        break;
    default :
        return false;
    }
    return true;
}

void Count(char s)
{
    switch(s)
    {
    case 'K':
    {
        int x = a.top();
        a.pop();
        int y = a.top();
        a.pop();
        a.push(x&&y);
        break;
    }
    case 'A':
    {
        int x = a.top();
        a.pop();
        int y = a.top();
        a.pop();
        a.push(x||y);
        break;
    }
    case 'N':
    {
        int x = a.top();
        a.pop();
        a.push(!x);
        break;
    }
    case 'C':
    {
        int x = a.top();
        a.pop();
        int y = a.top();
        a.pop();
        a.push((!x)||y);
        break;
    }
    case 'E':
    {
        int x = a.top();
        a.pop();
        int y = a.top();
        a.pop();
        a.push(x==y);
        break;
    }
    }
}
bool Col()
{
    int len = str.length();
    for(int i=0; i<32; i++)
    {
        Bit(i);
        for(int j=len-1; j>=0; j--)
        {
            if(!Judge(str[j]))
            {
                Count(str[j]);
            }
        }
        int x = a.top();
        a.pop();
        if(!x)
            return false;
    }
    return true;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(cin>>str && str[0]!='0')
    {
        if(Col())
            cout<<"tautology"<<endl;
        else
            cout<<"not"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值