POJ 1742 - Coins (dp 多重背包)

39 篇文章 0 订阅

Coins

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 28056 Accepted: 9492

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source


题意:

给出一些硬币的价值和数量,问用这些硬币能凑出多少种小于m的面值


多重背包



两种方法


第一种比较简单好想容易理解


#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <queue>
#include <set>

using namespace std;

//#define WIN
#ifdef WIN
typedef __int64 LL;
#define iform "%I64d"
#define oform "%I64d\n"
#else
typedef long long LL;
#define iform "%lld"
#define oform "%lld\n"
#endif

#define S64I(a) scanf(iform, &(a))
#define P64I(a) printf(oform, (a))
#define REP(i, n) for(int (i)=0; (i)<n; (i)++)
#define REP1(i, n) for(int (i)=1; (i)<=(n); (i)++)
#define FOR(i, s, t) for(int (i)=(s); (i)<=(t); (i)++)

const int INF = 0x3f3f3f3f;
const double eps = 10e-9;
const double PI = (4.0*atan(1.0));

const int maxn = 100 + 20;
const int maxm = 100000 + 20;
int v[maxn];
int c[maxn];
bool vis[maxm];
int use[maxm];

int main() {
    int n, m;

    while(scanf("%d%d", &n, &m) != EOF && !(!n && !m)) {
        for(int i=0; i<n; i++) scanf("%d", &v[i]);
        for(int i=0; i<n; i++) scanf("%d", &c[i]);
        memset(vis, 0, sizeof(vis));
        int ans = 0;
        vis[0] = true;
        for(int i=0; i<n; i++) {
            memset(use, 0, sizeof(use));
            for(int j=v[i]; j<=m; j++) {
                if(!vis[j] && vis[j-v[i]] && use[j-v[i]]<c[i]) {
                    vis[j] = true;
                    use[j] = use[j-v[i]] + 1;
                    ans++;
                }
            }
        }
        printf("%d\n", ans);
    }

    return 0;
}


另外一种

dp[i][j] 表示前i种硬币凑出j第i种硬币剩余的数量


#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <queue>
#include <set>

using namespace std;

//#define WIN
#ifdef WIN
typedef __int64 LL;
#define iform "%I64d"
#define oform "%I64d\n"
#else
typedef long long LL;
#define iform "%lld"
#define oform "%lld\n"
#endif

#define S64I(a) scanf(iform, &(a))
#define P64I(a) printf(oform, (a))
#define REP(i, n) for(int (i)=0; (i)<n; (i)++)
#define REP1(i, n) for(int (i)=1; (i)<=(n); (i)++)
#define FOR(i, s, t) for(int (i)=(s); (i)<=(t); (i)++)

const int INF = 0x3f3f3f3f;
const double eps = 10e-9;
const double PI = (4.0*atan(1.0));

const int maxn = 100 + 20;
const int maxm = 100000 + 20;
int v[maxn];
int c[maxn];
int dp[maxm];

int main() {
    int n, m;

    while(scanf("%d%d", &n, &m) != EOF && !(!n && !m)) {
        for(int i=0; i<n; i++) scanf("%d", &v[i]);
        for(int i=0; i<n; i++) scanf("%d", &c[i]);
        memset(dp, -1, sizeof(dp));
        dp[0] = 0;
        for(int i=0; i<n; i++) {
            for(int j=0; j<=m; j++) {
                if(dp[j] >= 0) {
                    dp[j] = c[i];
                } else if(j < v[i] || dp[j-v[i]] <= 0) {
                    dp[j] = -1;
                } else {
                    dp[j] = dp[j-v[i]] - 1;
                }
            }
        }
        int ans = 0;
        for(int i=1; i<=m; i++) if(dp[i] >= 0) ans++;
        printf("%d\n", ans);
    }

    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值