UVa 11375 - Matches (递推 JAVA 高精度)

UVA - 11375
Time Limit: 2000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

[]   [Go Back]   [Status]  

Description

Download as PDF

Problem E: Matches

We can make digits with matches as shown below:

Given N matches, find the number of different numbers representable using the matches. We shall only make numbers greater than or equal to 0, so no negative signs should be used. For instance, if you have 3 matches, then you can only make the numbers 1 or 7. If you have 4 matches, then you can make the numbers 1, 4, 7 or 11. Note that leading zeros are not allowed (e.g. 001, 042, etc. are illegal). Numbers such as 0, 20, 101 etc. are permitted, though.

Input

Input contains no more than 100 lines. Each line contains one integer N (1 ≤ N ≤ 2000).

Output

For each N, output the number of different (non-negative) numbers representable if you have N matches.

Sample Input

3
4

Sample Output

2
4


Problemsetter: Mak Yan Kei

[]   [Go Back]   [Status]  




题意:

用n根火柴能组成多少个非负数?火柴不必用完


f[i]表示恰好i根火柴能够组成的非负数个数,则在f[i]的基础上再加上数字x,那么就变为了用i+dx[x]根火柴的方案数

对于数字不能有前导零,在状态i=0的时候不能用0,在最后的时候如果i>=6(0需要的火柴数)的时候方案数加上1就行了


需要高精度


import java.util.*;
import java.math.*;

public class Main {
    public static void main(String[] args) {
        int maxn = 2000 + 20;
        int[] dx = {6, 2, 5, 5, 4, 5, 6, 3, 7, 6};
        BigInteger[] f = new BigInteger[maxn];
        BigInteger[] sum = new BigInteger[maxn];
        for(int i=1; i<maxn; i++) {
            f[i] = BigInteger.ZERO;
            sum[i] = BigInteger.ZERO;
        }
        f[0] = BigInteger.ONE;
        for(int i=0; i<maxn; i++) {
            for(int j=0; j<10; j++) {
                if((i!=0 || j!=0) && i + dx[j] < maxn) f[i+dx[j]] = f[i+dx[j]].add(f[i]);
            }
        }
        sum[0] = BigInteger.ZERO;
        for(int i=1; i<maxn; i++) sum[i] = sum[i-1].add(f[i]);
        Scanner in = new Scanner(System.in);
        while(in.hasNextInt()) {
            int n = in.nextInt();
            if(n < 6) System.out.println(sum[n]);
            else System.out.println(sum[n].add(BigInteger.ONE));
        }
    }
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值