1001. A+B Format

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991
import java.text.DecimalFormat;
import java.util.Scanner;

public class Main {

  public static void main(String[] args) {
    Scanner scanner = new Scanner(System.in);
    String input = scanner.nextLine();
    String[] arr = input.split(" ");
    int result = Integer.parseInt(arr[0]) + Integer.parseInt(arr[1]);
    DecimalFormat df = new DecimalFormat(",###");
    System.out.println(df.format(result));
  }

}

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
4月30日 09:36答案正确201001Java (javac 1.6.0)8110516zspring

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确79105089/9
1答案正确81103321/1
10答案正确79103321/1
11答案正确81104921/1
2答案正确80103361/1
3答案正确79104361/1
4答案正确80103761/1
5答案正确80103281/1
6答案正确79103601/1
7答案正确80103521/1
8答案正确80105161/1
9答案正确80104641/1
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值