线段树动态开点:

貌似权值线段树动态开点用的比较多。
例题:
I Hate It HDU - 1754

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取’Q’或’U’) ,和两个正整数A,B。
当C为’Q’的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为’U’的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
Output
对于每一次询问操作,在一行里面输出最高成绩。
Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
Sample Output
5
6
5
9

Hint
Huge input,the C function scanf() will work better than cin

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<queue>
#define ll long long
#define llu unsigned ll
using namespace std;
const int mod=1e9+7;
const int inf=0x3f3f3f3f;
const ll lnf=0x3f3f3f3f3f3f3f3f;
const int maxn=200100;
struct node
{
    int lc,rc;
    int maxx;
}t[maxn<<1];
int tot,root;

int build(void)
{
    tot++;
    t[tot].lc=t[tot].rc=t[tot].maxx=0;
    return tot;
}

void change(int p,int l,int r,int pos,int val)
{
    if(l==r)
    {
        t[p].maxx=val;
        return ;
    }
    int mid=(l+r)>>1;
    if(pos<=mid)
    {
        if(!t[p].lc) t[p].lc=build();
        change(t[p].lc,l,mid,pos,val);
    }
    else
    {
        if(!t[p].rc) t[p].rc=build();
        change(t[p].rc,mid+1,r,pos,val);
    }
    t[p].maxx=max(t[t[p].lc].maxx,t[t[p].rc].maxx);
}

int ask(int p,int L,int R,int l,int r)
{
    if(l<=L&&R<=r) return t[p].maxx;

    int ans=0;
    int mid=(L+R)>>1;
    if(l<=mid) ans=max(ans,ask(t[p].lc,L,mid,l,r));
    if(r>mid) ans=max(ans,ask(t[p].rc,mid+1,R,l,r));
    return ans;

}

int main(void)
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        tot=0;
        root=build();
        int cm;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&cm);
            change(root,1,n,i,cm);
        }
        char pos[20];
        int x,y;
        for(int i=1;i<=m;i++)
        {
            scanf("%s%d%d",pos,&x,&y);
            if(pos[0]=='Q')
                printf("%d\n",ask(root,1,n,x,y));
            else change(root,1,n,x,y);
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值