A+B Format(stack的使用)

1001 A+B Format (20 分)

题目链接
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991

题意:

计算两个数的和,并按每三位加一个“,”输出

注意:要从最后一位开始算起,这也是这道题的坑点之一

【分析】

只要明白栈的原理:先进后出,把结果值从最后一位开始入栈,这样出栈的话就可以每三位加一个‘,’输出,但是得注意负数的时候栈中会多出一个负号,得特判一下即可

#include<cstdio>
#include<cstring>
#include<string>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<stack>
#include<cstdlib>
#define eps 1e-9
const double pi = acos(-1.0);
#define ll long long
#define inf 0x3fffffff
const int N = 1010;
using namespace std;

int main()
{
	ll a, b, sum;
	stack<char>ss;
	cin >> a >> b;
	int cnt = 0;
	sum = a + b;

	string str = to_string(sum);//把结果存为字符串

	//cout << "此时结果为:" << str << endl;

	for (int i = str.size()-1; i >=0; i--)//运用栈的原理,
	{
		ss.push(str[i]);
		cnt++;
		
		//cout << "每一次的i的值:" << i << endl;

		if (i == 0)ss.push(str[i]);

		else if (cnt % 3 == 0 && str[i - 1] >= '0'&&str[i - 1] <= '9')
			{
				ss.push(',');
				cnt = 0;
			}
	}
	
	int f = 0;

	while (!ss.empty())
	{
		if (f == 0)ss.pop();//如果是负数的话,会多出一个“-”,所以要去掉第一个负号
		f = 1;
		cout << ss.top();
		ss.pop();
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值