E - Is It A Tree?
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
题解:题意是给出一堆边给你,让你判断这是不是一棵树,这与小希的迷宫是一样的思路,只要判断点与边是否满足点数 - 1 = 边数,满足就是树,否者就不是。
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int book[1001000];
int main()
{
int a,b,c=1;
while(~scanf("%d%d",&a,&b))
{
if(a==0&&b==0)
{
printf("Case %d is a tree.\n",c++);
continue;
}
int i,sum=1,ans=0;
for(i=0;i<=100050;i++)
{
book[i]=0;
}
if(a==-1&&b==-1)
break;
book[a]=1;//标记点
book[b]=1;
while(scanf("%d%d",&a,&b)&&(a||b))
{
sum++;//记录边数
book[a]=1;book[b]=1;//标记点
}
for(i=0;i<=100050;i++)
{
if(book[i])//判断标记的点数
ans++;
}
if(sum==ans-1)//要形成树就要满足点数-1=边数
printf("Case %d is a tree.\n",c++);
else
printf("Case %d is not a tree.\n",c++);
}
}