Wormholes

Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题解:N块地,M条路,W个虫洞。判断有没有可以是时间倒流的路径。用Bell-frod判断是否存在权回路。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int dis[10010],u[10010],v[10010],w[10010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i,j,n,m,s;
		int a,b,c;
		scanf("%d%d%d",&n,&m,&s);
		for (i=0;i<2*m; )
		{
			scanf("%d%d%d",&a,&b,&c);
			u[i]=a;
			v[i]=b;
			w[i++]=c;
			u[i]=b;
			v[i]=a;
			w[i++]=c;
		}
		for(i=2*m;i<2*m+s;i++)
		{
			scanf("%d%d%d",&a,&b,&c);//负权边 
			u[i]=a;
			v[i]=b;
			w[i]=-c;
		}
		for(i=0;i<=n;i++)
		  dis[i]=inf;
		dis[1]=0;
		int flag=1;
		for(int k=1;k<=n&&flag;k++)
		{
			flag=0;
			for(i=0;i<2*m+s;i++)
			{
				if(dis[v[i]]>dis[u[i]]+w[i])
				{
					dis[v[i]]=dis[u[i]]+w[i];
					flag=1;
				}				  
			}
		 } 
		 int f=0;
		for(i=0;i<3*m+s;i++)
		{
			if(dis[v[i]]>dis[u[i]]+w[i])//如果最短路发生变化,就存在负权回路 
			   f=1;
		}
		if(f==1)
		 printf("YES\n");
		else
		 printf("NO\n");
	}
}

  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值