DNA Sorting

Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

原题连接:点击打开链接

题意:给出DNA序列,求解每条序列的逆序对数,并按逆序对数从小到大排列。关键是如何求解逆序对数。

这里用的是二叉树。二叉树节点见代码的TreeNode,same表示跟该节点值相等的个数,初始值为1,small表示比该节点值小的值的个数。从每条DNA的最后一个节点开始,从后向前插入到二叉树中。然后在排序。

代码如下:

#include<iostream>
#include<string>
#include<algorithm>
#include<memory.h>
#include<limits.h>

using namespace std;

int res = 0;

struct TreeNode {
    char val;
    int small;
    int same;
    TreeNode *left,*right;
    TreeNode(char v) {
        val = v;
        same = 1;
        small = 0;
        left = right = NULL;
    }
};

struct Node {
    string str;
    int cnt;
};

TreeNode* insertTree(TreeNode *root, char key) {
    if(root == NULL) {
        root = new TreeNode(key);
    }
    else if(root->val == key) {
        res += root->small;
        root->same += 1;
    }
    else if(root->val < key) {
        res += root->small + root->same;
        root->right = insertTree(root->right,key);
    }
    else if(root->val > key) {
        root->small += 1;
        root->left = insertTree(root->left, key);
    }
    return root;
}

bool cmp(const Node &a,const Node &b) {
    return a.cnt < b.cnt;
}

int main() {
    Node arr[105];
    int m,n;
    cin>>m>>n;
    for(int i = 0; i < n; i++) {
        res = 0;
        string s;
        cin>>s;
        arr[i].str = s;

        TreeNode *root = NULL;
        for(int j = m-1; j >= 0; j--) {
            root = insertTree(root,s[j]);
        }
        arr[i].cnt = res;

    }
    sort(arr,arr+n,cmp);
    for(int i = 0; i < n; i++) {
        cout<<arr[i].str<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zhengjihao

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值