Exponentiation

Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001

1.126825030131969720661201

题意:浮点数的乘法。属于字符串处理类型。

代码如下:

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<limits.h>
#include<math.h>
#include<string>

using namespace std;

char ch[10] =  {'0','1','2','3','4','5','6','7','8','9'};
//两个字符串相加
string strAdd(string str1,string str2) {
    int c = 0,i,j;
    string res;
    i = str1.length()-1;
    j = str2.length()-1;
    while(i >= 0 && j >= 0) {
        int ci = str1[i] - '0';
        int cj = str2[j] - '0';
        int r = ci + cj + c;
        c = r / 10;
        res += ch[r%10];
        i--;j--;
    }
    while(i >= 0) {
        int ci = str1[i] - '0';
        int r = ci + c;
        c = r / 10;
        res += ch[r%10];
        i--;
    }
    while(j >= 0) {
        int cj = str2[j] - '0';
        int r = cj + c;
        c = r / 10;
        res += ch[r%10];
        j--;
    }
    if(c > 0) res += ch[c];
    reverse(res.begin(),res.end());
    return res;
}
//一个字符串乘以一个数字
string Single(string str,int num) {
    string res;
    int c = 0;
    for(int i = str.length()-1; i >= 0; i--) {
        int v = str[i] - '0';
        int sum = v * num + c;
        c = sum / 10;
        res += ch[sum % 10];
    }
    if(c > 0) res += ch[c];
    reverse(res.begin(),res.end());
    return res;
}
//字符串相乘
string strMultiply(string str1,string str2) {
    int dot = 0;
    int pos = str1.find('.');
    if(pos != string::npos) {
        dot += str1.length() - 1 - pos;
        str1.erase(str1.begin() + pos);
    }

    pos = str2.find('.');
    if(pos != string::npos) {
        dot += str2.length() - 1 - pos;
        str2.erase(str2.begin() + pos);
    }

    reverse(str2.begin(),str2.end());
    string res = "0";
    for(int i = 0; i < str2.length(); i++) {
        int num = str2[i] - '0';
        string tmp = Single(str1,num);
        for(int j = 0; j < i; j++) tmp += '0';
        res = strAdd(res,tmp);
    }
    res.insert(res.begin() + res.length() - dot,'.');
    return res;
}

int main() {
    string R;
    int n;
    while(cin>>R>>n) {
        string res  = "1";
        for(int i = 1; i <= n; i++) {
            res = strMultiply(res,R);
        }
        int i = 0;
        int j = res.length() - 1;
        while(res[i] == '0') i++;
        while(res[j] == '0') j--;
        if(res[j] == '.') j--;
        res = res.substr(i,j-i+1);
        cout<<res<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zhengjihao

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值