2018ACM-ICPC焦作赛区网络赛题目---Give Candies

                                                  Give Candies

  • 时间限制: 1000ms         内存限制: 65536K

There are N children in kindergarten. Miss Li bought them N candies. To make the process more interesting, Miss Li comes up with the rule: All the children line up according to their student number (1...N), and each time a child is invited, Miss Li randomly gives him some candies (at least one). The process goes on until there is no candy. Miss Li wants to know how many possible different distribution results are there.

Input

The first line contains an integer T, the number of test case.

The next T lines, each contains an integer N.

1≤T≤100

1≤N≤10^100000

Output

For each test case output the number of possible results (mod 1000000007).

样例输入

1
4

样例输出

8

思路:题目经过分析,答案就为计算2^(n-1)%mod的值即可,当n很大时,最大为10^100000,求2^n%mod   费马小定理求解,即有 2^n%mod=(2^(n%(mod-1))%mod; 

AC代码:

//当n很大时,最大为10^100000,求2^n%mod   费马小定理求解
//即有 2^n%mod=(2^(n%(mod-1))%mod; 
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long ll;
const ll mod=1000000007;
string s;
ll a[100010];
ll mod_pow(ll x,ll n){
    if(n==0) return 1;
    ll res=mod_pow(x*x%mod,n/2);
    if(n&1) res=res*x%mod;
    return res;
}
ll fun(ll k){
	ll sum=0;
	for(ll i=1;i<=k;i++){
		sum=(sum*10+a[i])%(mod-1);
	}
	return sum;
}
int main(){
	int t;
	cin>>t;
	while(t--){
		cin>>s;
		ll k=s.size();
		for(ll i=0;i<k;i++){
			a[i+1]=s[i]-'0';
		}
		ll n=fun(k);
		cout<<mod_pow(2,n-1)<<endl;
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值