poj 1753 Flip Game

Flip Game
 

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

 

                                                                      
Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

 

 

用位运算存每一个方格的中棋子的状态,这样就会有65536种状态, ‘b’为0,‘w’为1,然后再找到当前的起始状态对应的数,然后从当前状态开始广搜,直到搜到全黑或全白的状态停止。这道题用到了基本的位运算,通过这道题学到了不少位运算的知识

 

//代码是看了别人的,然后理解了写下来的

 

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;

int num;
const int white=(1<<16)-1;
const int black=0;
bool vis[1<<16];

struct node
{
  int state;
  int cnt;
};

struct node now,temp;

 

//记录下当前状态所对应的位置
bool bit()
{
  int i,j;
  char ch;
  num=0;
  int count=0;
  for(i=0;i<4;i++)
    for(j=0;j<4;j++)
    {
      cin>>ch;
      if(ch=='w')
        num+=(1<<count);
      count++;
    }
  if(num==white||num==black)
  {
    printf("0/n");
    return true;
  }
  return false;
}

 

//实现任意一步反转
void Flip(int x,int y)
{
  now.state^=1<<(4*x+y);
  if(x==0)
    now.state^=1<<(4+y);
  else if(x==3)
    now.state^=1<<(4*2+y);
  else
  {
    now.state^=1<<4*(x-1)+y;
    now.state^=1<<4*(x+1)+y;
  }
  if(y==0)
    now.state^=1<<4*x+1;
  else if(y==3)
    now.state^=1<<4*x+2;
  else
  {
    now.state^=1<<4*x+y-1;
    now.state^=1<<4*x+y+1;
  }
}

 

//遍历所有状态
void bfs()
{
  queue<struct node> q;
  vis[temp.state]=1;
  q.push(temp);
  while(!q.empty())
  {
    temp=q.front();
    q.pop();
    temp.cnt++;
    for(int i=0;i<4;i++)
      for(int j=0;j<4;j++)
      {
        now=temp;
        Flip(i,j);
        if(now.state==white||now.state==black)
        {
          cout<<now.cnt<<endl;
          return;
        }
        if(!vis[now.state])
        {
          vis[now.state]=1;
          q.push(now);
        }
      }
  }
  cout<<"Impossible"<<endl;
}

 

int main()
{
  if(!bit())
  {
    temp.state=num;
    temp.cnt=0;
    bfs();
  }
 
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值