E - Aggressive cows POJ - 2456

E - Aggressive cows POJ - 2456

Problem Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi

Output

  • Line 1: One integer: the largest minimum distance
    Sample Input

5 3
1
2
8
4
9
Sample Output

3
Hint

OUTPUT DETAILS:
FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
Huge input data,scanf is recommended.

使每头牛之间的距离尽可能小,求最小距离的最大值(典型二分标志)

题解

数据共有 n == 1e5 ,用数组储存距离差,排序,二分查找 0 ~ (Xn / C) 中满足条件的值
判断依据: c*mid < x[N]-x[0]

复杂度

1e9 的数据不爆 int
O(n + nlogn + logn)== O(nlogn) = 1e6 ~ 1e7

算法

二分

代码

  1. 手写二分
#include<bits\stdc++.h>
using namespace std;
const int maxn = 1e9;
#define ll long long
int N, C, l, r, mid;
int x[100005];

bool check() {
	int ans = x[1];
	int cnt = 1;
	for(int i = 2; i <= N; i++) {
		if(x[i]-ans >= mid) {
			cnt++;
			ans = x[i];
		}
		//if(cnt == C) return (C-1)*mid < x[N] ? 1 : 0;
		if(cnt >= C) return 1;
	}
	return 0;
}

int main() {
	freopen("test.in", "r", stdin);
	while(cin >> N >>C) {
		memset(x, 0, sizeof(x));
		for(int i = 1; i <= N; i++) {
			cin >> x[i];
		}
		sort(x+1, x+N+1);
		l = 0, r = maxn/C;
		while(l <= r) {
			mid = l + (r-l)/2;
			if(check()){
				l = mid + 1;
			}
			else{
				r = mid - 1;
			}
		}
		printf("%d\n", l);
	}
	return 0;
}
  1. lower_bound()
    (没调出来,有bug)
#include<bits\stdc++.h>
using namespace std;
const int maxn = 1e9;
#define ll long long
int N, C, l, r, mid;
int x[100005];

bool check() {
	int ans = x[1];
	for(int i = 1; i <= C; i++) {
		int temp = lower_bound(x+1, x+N+1, ans+mid) - &x[1]; // 求出下标差
		if(temp == N) break;
		else ans = x[temp];
		if(i == C) return 1;
	}
	return 0;
}

int main() {
	freopen("test.in", "r", stdin);
	while(cin >> N >> C) {
		memset(x, 0, sizeof(x));
		for(int i = 1; i <= N; i++) {
			cin >> x[i];
		}
		sort(x+1, x+N+1);
		cout << "*" << endl;
		l = 0, r = maxn/C;
		while(l <= r) {
			cout << "**" << endl;
			mid = l + (r-l)>>2;
			if(check()){
				l = mid + 1;
			}
			else{
				r = mid - 1;
			}
		}
		printf("%d\n", l);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值