PAT(Advanced level) 1002. A+B for Polynomials

原题链接:http://pat.zju.edu.cn/contests/pat-a-practise/1002

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
#include <stdio.h>
#include <vector>
#include <algorithm>
using namespace std;
struct Term
{
  int exp;//指数
  double coe;//系数
};
const double threshold = 0.0000001;
void PrintTerm(Term term)
{
  printf(" %d %0.1lf", term.exp, term.coe);
}

int main()
{
  int k1, k2;
  vector<Term> line1;
  vector<Term> line2;
  vector<Term> sum;
  scanf("%d", &k1);
  for(int i=0; i<k1; ++i)
  {
    Term term;
    scanf("%d %lf", &term.exp, &term.coe);
    line1.push_back(term);
  }
  scanf("%d", &k2);
  for(int i=0; i<k2; ++i)
  {
    Term term;
    scanf("%d %lf", &term.exp, &term.coe);
    line2.push_back(term);
  }
  int i=0,j=0;
  for(; i<k1 && j<k2; )
  {
    if(line1[i].exp == line2[j].exp)
    {
      Term term;
      term.exp = line1[i].exp;
      term.coe = line1[i].coe+line2[j].coe;
      if(term.coe > threshold || term.coe < -threshold)
      {
        sum.push_back(term);
      }
      ++i;
      ++j;
    }
    else if (line1[i].exp < line2[j].exp)
    {
      sum.push_back(line2[j]);
      ++j;
    }
    else 
    {
      sum.push_back(line1[i]);
      ++i;
    }//end if
  }// end for
  while(i < k1)
  {
    sum.push_back(line1[i]);
    ++i;
  }
  while(j < k2)
  {
    sum.push_back(line2[j]);
    ++j;
  }
  printf("%d", sum.size());
  for_each(sum.begin(), sum.end(), PrintTerm);
  printf("\n");
  line1.clear();
  line2.clear();
  sum.clear();
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值