PAT(Advanced level) 1009. Product of Polynomials

原题链接:http://pat.zju.edu.cn/contests/pat-a-practise/1009

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
#include <stdio.h>
#include <vector>
using namespace std;
struct Term
{
  int exp;
  double coe;
};
const int N = 2001;
const double zero = 0.0000001;
int main()
{
  vector<Term> first;
  vector<Term> second;
  double result[N] = {0};
  int k1, k2;
  int num = 0;
  scanf("%d", &k1);
  for(int i=0; i<k1; ++i)
  {
    Term term;
    scanf("%d %lf", &term.exp, &term.coe);
    first.push_back(term);
  }
  scanf("%d", &k2);
  for(int i=0; i<k2; ++i)
  {
    Term term;
    scanf("%d %lf", &term.exp, &term.coe);
    second.push_back(term);
  }
  for(int i=0; i<k1; ++i)
  {
    Term term1 = first[i];
    for(int j=0; j<k2; ++j)
    {
      Term term2 = second[j];
      int exp = term1.exp +term2.exp;
      result[exp] += term1.coe * term2.coe;
    }
  }
  for(int i=0; i<N; ++i)
  {
    if(result[i] > zero || result[i] < -zero)
    {
      ++num;
    }
  }
  printf("%d", num);
  for(int i=N-1; i>=0; --i)
  {
    if(result[i] > zero || result[i] < -zero)
    {
      printf(" %d %0.1lf", i, result[i]);
    }
  }
  printf("\n");
  first.clear();
  second.clear();
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值