This app has been built with an incorrect configuration. Please configure your build for VectorDrawa

我相信很多朋友在辛辛苦苦的开发后,明明自己手机可以正常安装与运行,但是总有那么些用户是运行不行的,开始的时候我也纳闷了好久,因为没有用户的那款手机型号,都不知道报的什么错,也无法对症下药,愁了好几天,今天突然试试虚拟机,结果这种问题居然呈现了。相信很多开发朋友也和我一样,不怕有错,就怕没有错吧,等上线后一堆的错,简直不能忍。


特征:正常安装,不能运行

报错:Caused by:java.lang.RuntimeException: Unable to start activity ComponentInfo{com.test.rx/com.test.zh.MainActivity}: java.lang.IllegalStateException: This app has been built with an incorrect configuration. Please configure your build for VectorDrawableCompat.

翻译:这个应用程序已经建立了一个不正确的配置。请配置您的构建vectordrawablecompat。


其实吧,原因是:Android 插件版本不兼容,需要gradle 2.0以上就可以了 。




解决方案:
(1)将build.gradle中的版本改为2.0.0,如下图所示。
buildscript {
    repositories {
        jcenter()
    }
    dependencies {
//        classpath 'com.android.tools.build:gradle:1.5.0'
        classpath 'com.android.tools.build:gradle:2.0.0'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

(2)选择工具栏上的Tools->Android->Sync Project with Gradle Files,同步一下Gradle, 此时会在控制台出错如下错误:

Warning:Gradle version 2.10 is required. Current version is 2.8. If using the gradle wrapper, try editing the distributionUrl in E:\ZH\gradle\wrapper\gradle-wrapper.properties to gradle-2.10-all.zip


(3)根据指出的路径找到\gradle\wrapper\gradle-wrapper.properties文件,将Gradle的版本改为2.10-all,如下图所示:


#Wed Oct 21 11:34:03 PDT 2015
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
#distributionUrl=https\://services.gradle.org/distributions/gradle-2.8-all.zip
distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip


(4)重新编译运行,就可以正常使用了


阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zhihui_520/article/details/52189139
个人分类: 开发问题
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭