Tickets (简单dp)

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
Output For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am

题目大意:给你n组数据,每组数据给你一个k表示总人数,后面一行表示k个人每个人买票花费的时间,再后面一行k-1个数字表示前后两个人一起买票花费的时间。

很简单的一个dp题。

一维的状态转移方程:dp[i] = min(dp[i-1]+s[i],dp[i-2]+d[i]);

二维的状态转移方程:dp[i][0]=a[i]+min(dp[i-1][0],dp[i-1][1]);    dp[i][1]=b[i]+min(dp[i-2][0],dp[i-2][1]); 

                                  dp[i][0]表示第i个人自己一个人买票,dp[i][1]表示与前一个人一起买票。


上代码(一维):

#include <iostream>
#include <string>
#include <sstream>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <ctime>
#include <vector>
#include <set>
#include <sstream>
#include <map>
#include <cctype>

using namespace std;
#define Start clock_t start = clock();
#define End clock_t end = clock();
#define Print cout<<(double)(end-start)/CLOCKS_PER_SEC*1000<<"ºÁÃë"<<endl;

const int maxn = 10000 + 5;
int t,n;
int d[maxn],s[maxn],dp[maxn];
int main()
{
    int hh,mm,ss;
    scanf("%d",&t);
    while (t--) {
        scanf("%d",&n);
        for (int i = 1;i <= n;i++)
            scanf("%d",&s[i]);
        for (int i = 2;i <= n;i++)
            scanf("%d",&d[i]);
        dp[1] = s[1];
        for (int i = 2;i <= n;++i)
                dp[i] = min(dp[i-1]+s[i],dp[i-2]+d[i]);
        hh = dp[n]/3600;
        mm = dp[n]%3600/60;
        ss = dp[n]%60;
        printf("%02d:%02d:%02d%s\n",(8+hh)%24,mm,ss,(hh+8)%24>12?" pm":" am");
    }

    return 0;
}

上代码(二维):

#include <iostream>
#include <string>
#include <sstream>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <ctime>
#include <vector>
#include <set>
#include <sstream>
#include <map>
#include <cctype>

using namespace std;
#define Start clock_t start = clock();
#define End clock_t end = clock();
#define Print cout<<(double)(end-start)/CLOCKS_PER_SEC*1000<<"ºÁÃë"<<endl;
#define INF 1001000
const int maxn = 10000 + 5;
int n;
int a[maxn],b[maxn];
int dp[maxn][2];

int main() {
    int t;
    cin>>t;
    while(t--) {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        b[0]=INF;
        for(int i=2; i<=n; i++)
            scanf("%d",&b[i]);
        dp[1][0]=a[1];
        dp[1][1]=INF;
        dp[0][0]=0;
        dp[0][1]=0;
        for(int i=2; i<=n; i++) {
            dp[i][0]=a[i]+min(dp[i-1][0],dp[i-1][1]);
            dp[i][1]=b[i]+min(dp[i-2][0],dp[i-2][1]);
        }
        int ans=min(dp[n][1],dp[n][0]);
        int se=ans%60;
        ans/=60;
        int mins=ans%60;
        ans/=60;
        int h=ans+8;
        int flag=0;
        if(h<10)printf("0%d:",h);
        else if(h>=10&&h<=11)printf("%d:",h);
        else {
            int hh=h-12;
            if(hh<10)printf("0");
            printf("%d:",hh);
            flag=1;
        }
        if(mins<10)printf("0");
        printf("%d:",mins);
        if(se<10)
            printf("0");
        printf("%d",se);
        if(flag)printf(" pm\n");
        else printf(" am\n");
    }

    return 0;
}
希望能有帮助。
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值