HDU4908 BestCoder Sequence

BestCoder Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1955    Accepted Submission(s): 653


Problem Description
Mr Potato is a coder.
Mr Potato is the BestCoder.

One night, an amazing sequence appeared in his dream. Length of this sequence is odd, the median number is M, and he named this sequence as  Bestcoder Sequence.

As the best coder, Mr potato has strong curiosity, he wonder the number of consecutive sub-sequences which are  bestcoder sequences in a given permutation of 1 ~ N.
 

Input
Input contains multiple test cases. 
For each test case, there is a pair of integers N and M in the first line, and an permutation of 1 ~ N in the second line.

[Technical Specification]
1. 1 <= N <= 40000
2. 1 <= M <= N
 

Output
For each case, you should output the number of consecutive sub-sequences which are the  Bestcoder Sequences
 

Sample Input
  
  
1 1 1 5 3 4 5 3 2 1
 

Sample Output
  
  
1 3
Hint
For the second case, {3},{5,3,2},{4,5,3,2,1} are Bestcoder Sequence.

题意:给一个数字序列1~n(n个数字各不相同),和一个数字m,求m作为连续的自序列的中位数的序列个数。

题解:组合数学。先找到m,开一个数组f[2][N],分别遍历m的左右两边,如果数字大于m,则cnt++,小于则cnt--,然后在f数组中记录下cnt的个数,即记录m左右两边区间比m大的和小的差值的个数,再相乘。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
typedef long long ll;
#define N 40005
 
int a[N];
long long f[2][N*2];
void fun(int n, int m, int pos){
	memset(f, 0, sizeof(f));
	int cnt = 0;
	for(int i = pos-1; i >= 0; i--){
		if(a[i] > m)
			cnt++;
		else
			cnt--;
		f[0][cnt+n]++;
	}
	cnt = 0;
	for(int i = pos+1; i < n; i++){
		if(a[i] > m)
			cnt++;
		else
			cnt--;
		f[1][cnt+n]++;
	}
}

int main(){
	int n, m, x;
	while(scanf("%d%d", &n, &m) != EOF){
		ll ans = 0;
		int pos;
		for(int i = 0; i < n; i++){
			scanf("%d", &a[i]);
			if(a[i] == m)
				pos = i;
		}
		fun(n, m, pos);
		for(int i = 0; i <= n; i++){
			ans += f[0][i+n] * f[1][n-i] + f[1][i+n] * f[0][n-i];
		}
		ans += f[0][n] + f[1][n] - f[0][n]*f[1][n];
		printf("%lld\n", ans + 1);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值