HDU4932 Miaomiao's Geometry

Miaomiao's Geometry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length.

There are 2 limits:

1.A point is convered if there is a segments T , the point is the left end or the right end of T.
2.The length of the intersection of any two segments equals zero.

For example , point 2 is convered by [2 , 4] and not convered by [1 , 3]. [1 , 2] and [2 , 3] are legal segments , [1 , 2] and [3 , 4] are legal segments , but [1 , 3] and [2 , 4] are not (the length of intersection doesn't equals zero), [1 , 3] and [3 , 4] are not(not the same length).

Miaomiao wants to maximum the length of segements , please tell her the maximum length of segments.

For your information , the point can't coincidently at the same position.
 

Input
There are several test cases.
There is a number T ( T <= 50 ) on the first line which shows the number of test cases.
For each test cases , there is a number N ( 3 <= N <= 50 ) on the first line.
On the second line , there are N integers Ai (-1e9 <= Ai <= 1e9) shows the position of each point.
 

Output
For each test cases , output a real number shows the answser. Please output three digit after the decimal point.
 

Sample Input
  
  
3 3 1 2 3 3 1 2 4 4 1 9 100 10
 

Sample Output
  
  
1.000 2.000 8.000
Hint
For the first sample , a legal answer is [1,2] [2,3] so the length is 1. For the second sample , a legal answer is [-1,1] [2,4] so the answer is 2. For the thired sample , a legal answer is [-7,1] , [1,9] , [10,18] , [100,108] so the answer is 8.
题意:在x轴上有一些不重复的点,要求用线段覆盖它们,覆盖的规则是:

1、线段的左断点或右端点落在点上才算覆盖这个点

2、线段不能重叠

问最长的线段是多长?

题解:这个长度肯定是两个点之间的距离,或者距离的一半。所以枚举这个距离,判断是否符合要求就行了,记录下最大的值。判断时用贪心,先判断点的左边能不能放线段,不能的话就放在右边,都不能的话,则不满足。最两端的端点可以不用判断。


代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
#define INF 2e9+5
double a[55], b[105];
bool judge(double x, int n){
	int flag = 0;
	for(int i = 1; i < n-1; i++){
		if(flag == 0){
			if(a[i] - a[i-1] < x){
				flag = 1;
				if(a[i+1]-a[i] < x)
					return 0;
			}
		}
		else{
			if(a[i] - a[i-1] >= x*2 || a[i] - a[i-1] == x)
				flag = 0;
			else{
				if(a[i+1] - a[i] < x)
					return 0;
			}
		}
	}
	return 1;
}
int main(){
	int t, n;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		for(int i = 0; i < n; i ++){
			scanf("%lf", &a[i]);
		}
		sort(a, a+n);
		for(int i = 1; i < n; i++){
			b[i] = a[i] - a[i-1];
		}
		sort(b+1, b+n);
		double ans = 0;
		for(int i = 1; i < n; i++){
			if(i > 0 && b[i] == b[i-1])continue;
			if(judge(b[i], n))
				ans = max(ans, b[i]);
			else if(judge(b[i]/2, n))
				ans = max(ans, b[i]/2);
		}
		printf("%.3lf\n", ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值