HDU 4965 Fast Matrix Calculation

Fast Matrix Calculation
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2184 Accepted Submission(s): 1024

Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N).
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’.

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.

Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.

Output
For each case, output the sum of all the elements in M’ in a line.

Sample Input
4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0

Sample Output
14
56

Author
SYSU

Source
2014 Multi-University Training Contest 9

题意:给了两个矩阵A,B,(A*B) NN N ∗ N 得到一个矩阵,求这个矩阵所有元素模6之后的新矩阵的元素和
分析:矩阵快速幂,由于n为1000,不可能用N*N的矩阵做快速幂,而K很小,可以转化成A*(B*A) NN1 N ∗ N − 1 * B。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<stack>
using namespace std;
typedef long long ll;
int N,K;
const int INF = 0x3f3f3f3f;
const int mod = 6;
const int maxn = 1010;
typedef struct
{
    int m[10][10];
} Matrix;
Matrix C;
int A[maxn][maxn],B[maxn][maxn],ans[maxn][maxn],res[maxn][maxn];
Matrix mul(Matrix a,Matrix b)
{
    Matrix c;
    for(int i = 1; i <= K; i++)
        for(int j = 1; j <= K; j++)
        {
            c.m[i][j] = 0;
            for(int k = 1; k <= K; k++)
            {
                c.m[i][j] += (a.m[i][k] * b.m[k][j]) % mod;
                c.m[i][j] %= mod;
            }
        }
    return c;
}
Matrix quickpow(Matrix x,int n)
{
    Matrix I;
    for(int i = 1; i <= K; i++)
    {
        for(int j = 1; j <= K; j++)
        {
        if(i == j)
            I.m[i][j] = 1;
        else
            I.m[i][j] = 0;
        }
    }

    Matrix m = x;
    while(n > 0)
    {
        if(n & 1)
            I = mul(m,I);
        m = mul(m, m);
        n >>= 1;
    }
    return I;
}
int main()
{

    while(cin>>N>>K)
    {
        if(N== 0 && K == 0)
            break;
        for(int i = 1; i <= N; i++)
            for(int j = 1; j <= K; j++)
            {
                int x;
                cin>>x;
               A[i][j] = x;
            }
        for(int i = 1; i <= K; i++)
            for(int j = 1; j <= N; j++)
            {
                int x;
                cin>>x;
                B[i][j] = x;
            }
        for(int i = 1; i <= K; i++)
            for(int j = 1; j <= K; j++)
            {
                C.m[i][j] = 0;
                for(int l = 1; l <= N; l++)
                {
                    C.m[i][j] += B[i][l] * A[l][j];
                }
            }

        Matrix tmp = quickpow(C,N * N - 1);
        memset(ans,0,sizeof(ans));
        for(int i = 1; i <= N; i++)
            for(int j = 1; j <= K; j++)
        {
            ans[i][j] = 0;
            for(int l = 1; l <= K; l++)
            {
                ans[i][j] += (A[i][l] * tmp.m[l][j]) % mod;
                ans[i][j] %= mod;
            }
        }
        memset(res,0,sizeof(res));
        for(int i = 1; i <= N; i++)
            for(int j = 1; j <= N; j++)
        {
            res[i][j] = 0;
            for(int l = 1; l <= K; l++)
            {
                res[i][j] += (ans[i][l] * B[l][j]) % mod;
                res[i][j] %= mod;
            }
        }


        int sum = 0;
        for(int i = 1; i <= N; i++)
            for(int j = 1; j <= N; j++)
                sum += res[i][j];
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值