1112 Stucked Keyboard (20分) (含测试点1分析)

1112 Stucked Keyboard (20分)

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:
Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:
For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

本题分析:

测试点1的问题:
类似于下面的例子

3
aaabbbcccabc

一开始判断会把a,b,c判断成Stucked Keyboard,但是后面又出现了不符合条件的相同字符,说明该字符应该不是Stucked Keyboard。此时应把之前的判断撤销。

我的做法是先遍历字符串每次求出相邻的相同字符的长度,如果满足(j-i)%n== 0,则说明这个字符存在需要处理的可能性,如果之前没有判断该字符是不需要处理的话,先加入set,如果后来发现该字符出现时不满足(j-i)%n == 0,则说明该字符是不需要处理的,用set中的erase及find函数删除该字母

#include<iostream>
#include<set>
#include<algorithm>
#include<vector>

using namespace std;
int n,j,len;
set<char> nore,re,p;
string a;
int main()
{
    string res="";
    cin >> n >> a;
    for(int i=0;i<a.size();)
    {
        j=i;
        while(a[j]==a[i])
            j++;
        if((j-i)%n==0&&nore.find(a[i])==nore.end())
        {
            if(re.find(a[i])==re.end())
                re.insert(a[i]);
        }
        else if((j-i)%n!=0&&re.find(a[i])!=re.end())
        {
            re.erase(re.find(a[i]));
            nore.insert(a[i]);
        }
        else if((j-i)%n!=0)
            nore.insert(a[i]);
        i=j;
    }
    for(int i=0;i<a.size();)
    {
        if(re.find(a[i])==re.end())
        {
            res+=a[i];
            i++;
        }
        else
        {
            if(p.find(a[i])==p.end())
            {
                p.insert(a[i]);
                printf("%c",a[i]);
            }
            res+=a[i];
            i+=n;
        }
    }
    printf("\n");
    cout << res;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值