1128 N Queens Puzzle (20分)

1128 N Queens Puzzle (20分)

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q​1​​ ,Q​2​​ ,⋯,Q​N​​ ), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.

在这里插入图片描述
Figure 1
在这里插入图片描述
Figure 2

Input Specification:
Each input file contains several test cases.
The first line gives an integer K (1<K≤200).
Then K lines follow, each gives a configuration in the format "N Q​1​​ Q​2​​ … Q​N​​ ", where 4≤N≤1000 and it is guaranteed that 1≤Q​i​​ ≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:
For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

本题思路:对于每一组数据,用几个数组来记录数据不重复即可,因为是按列排序的,因此只需要保证行(row)不重复,主对角线(col+row)不重复,反对角线(col-row)不重复即可,(需要注意的是计算反对角线时可能会出现col-row<0的情况下,而数组不存在下标为负数的情况,因此只需整体右移N个单位即可)

AC代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int main()
{
    int n;
    cin >> n;
    while(n--)
    {
        bool flag=true;
        int k;
        cin >> k;
        vector<int> row(k+1,0);
        vector<int> dia(2*k+2,0);
        vector<int> backdia(2*k+2,0);
        vector<int> list(k+1,0);
        for(int i=1;i<=k;i++)
        {
            cin >> list[i];
            row[list[i]]++;
            if(row[list[i]]>1)
                flag=false;
            dia[i+list[i]]++;
            if(dia[i+list[i]]>1)
                flag=false;
            backdia[i-list[i]+k]++;
            if(backdia[i-list[i]+k]>1)
                flag=false;
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值