1137 Final Grading (25分)

1137 Final Grading (25分)

For a student taking the online course “Data Structures” on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(G​mid−term​​ ×40%+G​final​​ ×60%) if G​mid−term​​ >G​final​​ , or G​final​​ will be taken as the final grade G. Here G​mid−term​​ and G​final​​ are the student’s scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores G​p​​ 's; the second one contains M mid-term scores G​mid−term​ 's; and the last one contains N final exam scores G
​final​​ 's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:
For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID G​p​​ G​mid−term​​ G​final​​ G

If some score does not exist, output “−1” instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID’s. It is guaranteed that the StudentID’s are all distinct, and there is at least one qullified student.

Sample Input:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

本题思路:在读取数据的时候可以直接去除一些不合格的人,首先是将Gp成绩<200的学生全部排除,并用set记录合格的人的名字,由期末成绩的运算公式可知合格学生不可能出现未参加期末考的情况,不然总成绩最多40不可能合格,同时如果参加了期中期末但没有Gp也是一样不行的,因此只要在Gp合格的人和参加期末考的人的交集才有可能会合格,利用分数计算公式分类讨论计算总分,合格的将其node加入数组,最后对数组进行排序。

AC代码:

#include<iostream>
#include<unordered_map>
#include<unordered_set>
#include<vector>
#include<algorithm>
using namespace std;

struct node{
    string name;
    int gp;
    int mid=-1;
    int final=-1;
    int sum=-1;
};

unordered_map<string,node> list;
vector<node> ans;
unordered_set<string> gp_list;
int p,m,n;

bool cmp(node a,node b)
{
    if(a.sum!=b.sum)
        return a.sum>b.sum;
    else
        return a.name<b.name;
}

int main()
{
    cin >> p >> m >> n;
    for(int i=0;i<p;i++)
    {
        string na;
        int gp;
        cin >> na >> gp;
        if(gp>=200)
        {
            node a;
            a.name=na;
            a.gp=gp;
            list[na]=a;
            gp_list.insert(na);
        }
    }
    for(int i=0;i<m;i++)
    {
        string na;
        int mid;
        cin >> na >> mid;
        if(gp_list.find(na)!=gp_list.end())
            list[na].mid=mid;
    }
    for(int i=0;i<n;i++)
    {
        string na;
        int score;
        cin >>na >> score;
        if(gp_list.find(na)!=gp_list.end())
        {
            list[na].final=score;
            if(list[na].mid==-1)
                list[na].sum=score;
            else
                if(list[na].mid>list[na].final)
                    list[na].sum=int(0.4*list[na].mid+0.6*list[na].final+0.5);
                else
                    list[na].sum=list[na].final;
            if(list[na].sum>=60)
                ans.push_back(list[na]);
        }
    }
    
    sort(ans.begin(),ans.end(),cmp);
    for(int i=0;i<ans.size();i++)
    {
        if(i!=0)
            printf("\n");
        printf("%s %d %d %d %d",ans[i].name.c_str(),ans[i].gp,ans[i].mid,ans[i].final,ans[i].sum);
    }
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值