nefu604X的尾巴 快速幂取模

开始寻思半天是什么算法==原来是这货==注意答案开头有0的处理 机智如我

description

求出X^X(X的X次方)后四位的数值。

input

测试数组有多组,每行输入一个整数x,(1<=x<=100000000)

output

对于每次输入,对应输出相应x的后四位数,每个输出占一行。

sample_input

1
2
3
10

sample_output

1
4
27
0000
#include <iostream>
#include<cstdio>
using namespace std;
long long quickmod(long long a,long long b)
{
     long long ans=1;
     while(b)
     {
          if(b&1)
          {
               ans=(ans*a)%10000;
          }
          b/=2;
          a=a*a%10000;
     }
     return ans;
}
int main()
{
    long long x;
    while(~scanf("%lld",&x))
    {
         if(x==0) printf("0\n");
         else
         {
         long long ans=quickmod(x,x);
         if(x<6) printf("%lld\n",ans);
         else printf("%04lld\n",ans);
         }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值