spoj1182Sorted bit squence【数位dp】

Description

Let's consider the 32 bit representation of all integers i from m up to n inclusive (m ≤ i ≤ n; m × n ≥ 0, -2^31 ≤ m ≤ n ≤ 2^31-1). Note that a negative number is represented in 32 bit Additional Code. That is the 32 bit sequence, the binary sum of which and the 32 bit representation of the corresponding positive number is 2^32 (1 0000 0000 0000 0000 0000 0000 0000 0000 in binary).

For example, the 32 bit representation of 6 is 0000 0000 0000 0000 0000 0000 0000 0110

and the 32 bit representation of -6 is 1111 1111 1111 1111 1111 1111 1111 1010

because

0000 0000 0000 0000 0000 0000 0000 0110 (6)
+
1111 1111 1111 1111 1111 1111 1111 1010 (-6)
-------------------------------------------------
= 1 0000 0000 0000 0000 0000 0000 0000 0000 (2^32)

Let's sort the 32 bit representations of these numbers in increasing order of the number of bit 1. If two 32 bit representations that have the same number of bit 1, they are sorted in lexicographical order.

For example, with m = 0 and n = 5, the result of the sorting will be

No.

Decimal number

Binary 32 bit representation

1

0

0000 0000 0000 0000 0000 0000 0000 0000

2

1

0000 0000 0000 0000 0000 0000 0000 0001

3

2

0000 0000 0000 0000 0000 0000 0000 0010

4

4

0000 0000 0000 0000 0000 0000 0000 0100

5

3

0000 0000 0000 0000 0000 0000 0000 0011

6

5

0000 0000 0000 0000 0000 0000 0000 0101

with m = -5 and n = -2, the result of the sorting will be

No.

Decimal number

Binary 32 bit representation

1

-4

1111 1111 1111 1111 1111 1111 1111 1100

2

-5

1111 1111 1111 1111 1111 1111 1111 1011

3

-3

1111 1111 1111 1111 1111 1111 1111 1101

4

-2

1111 1111 1111 1111 1111 1111 1111 1110

Given m, n and k (1 ≤ k ≤ min{n − m + 1, 2 147 473 547}), your task is to write a program to find a number corresponding to k-th representation in the sorted sequence.

Input

The input consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 1000. The following lines describe the data sets.

For each data set, the only line contains 3 integers m, n and k separated by space.

Output

For each data set, write in one line the k-th number of the sorted numbers.

Example

Sample input:
2
0 5 3
-5 -2 2

Sample output:
2
-5 

各种不应该的错误==忘记初始化,前后不对应,T^T卡了一天啊

我们首先考虑m、n同正的情况。
由于排序的第一关键字是1 的数量,第二关键字是数的大小,因此我们很容易确定答案中1 的个数:依次统计区间[m,n]内二进制表示中含1的数量为0,1,2,…的数,直到累加的答案超过k,则当前值就是答案含1的个数,假设是s。利用例一的算法可以解决这个问题。
同时,我们也求出了答案是第几个[m,n]中含s个1 的数。因此,只需二分答案,求出[m,ans]中含s个1 的数的个数进行判断即可。
由于每次询问的复杂度为O(log(n)),故二分的复杂度为O(log2(n)),这同时也是预处理的复杂度,因此此算法较为理想。
m<0的情况,也不难处理,我们只要忽略所有数的最高位,求出答案后再将最高位赋回1 即

/**********************
spoj1182
2016.2.17
3379	0
C++ (g++ 4.9.2)
	1526
2016-02-17 14:42:14
**********************/
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,m,k,f[33][33];
void init()
{
    f[0][0]=1;
    for(int i=1;i<=32;i++)
    {
        f[i][0]=f[i-1][0];
        for(int j=1;j<=i;j++) f[i][j]=f[i-1][j-1]+f[i-1][j];
    }
}
int cal(int x,int k)
{
    int sum=0,tot=0,pos=0;
    int bit[33];
    memset(bit,0,sizeof(bit));
    while(x)
    {
        bit[++pos]=x%2;
        x/=2;
    }
    for(int i=pos;i>=1;i--)
    {
        if(!bit[i]) continue;
        sum+=f[i-1][k-tot];
        tot++;
        if(tot>=k) break;
    }
    if(tot==k) sum++;
    return sum;
}
int fnd(int l,int r,int k)
{
    int i,num;
    for(i=1;i<=31;i++)
    {
        num=cal(r,i)-cal(l-1,i);
        if(num>=k) break;
        else k-=num;
    }
    int tmp=l;
    while(l<=r)
    {
        int mid=l+(r-l)/2;
        num=cal(mid,i)-cal(tmp-1,i);
        if(num>=k) r=mid-1;
        else l=mid+1;
    }
    return l;
}
int main()
{
   // freopen("cin.txt","r",stdin);
    int t;
    init();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&m,&n,&k);
        if(m<0)
        {
            m&=~(1<<31);
            if(n==0)
            {
                n--;
                k--;
            }
            n&=~(1<<31);
           // printf("m=%d n=%d\n",m,n);
            printf("%d\n",(1<<31)|fnd(m,n,k));
        }
        else
        {
            if(m==0) k--,m++;
            printf("%d\n",fnd(m,n,k));
        }
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值