2015多校联合第三场 hdu5317 RGCDQ

Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  maxGCD(F(i),F(j))   (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query,output the answer in a single line. 
See the sample for more details.
 

Sample Input
  
  
2 2 3 3 5
 

Sample Output
  
  
1 1

这个题一看 ,问区间内最大的素因子个数,素数筛预处理+素因子分解果断超时 优化到不能再优化 依旧超时  how?

又是思维固化了orz  问素数个数不一定要求出素数啊 ~ init()函数用以求出每个数的素数种类 num[ ][ ]数组干嘛的 困扰了我一天 一重维度是每个数 另一重是每个数的质因子种类数 

什么跟什么啊这是  ̄□ ̄|| 然后还把前一行的复制到下一行 下一行还有++ ……直到我枚举了前几个数

   i\f[i]1234567
21000000
32000000
43000000
54000000
64100000
75100000
86100000
97100000
107200000
118200000

其中有一个结论是10^6的范围内 某数的质因子种类不会超过7 (把前7个素数2、3、5、7、11、13……乘一起也超过10^6了)

num[ ][ ]表示截止到某数 有1、2、3、……个素因子种类的数有多少个 嗯嗯 求区间减一下就好了 

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
#include<math.h>
#include<limits.h>
#include<time.h>
#include<stdlib.h>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
#define LL long long

using namespace std;

int f[1000005];
int num[1000005][8];
void init()
{
    for(int i = 2; i < 1000005; i++)
    {
        if(f[i] == 0)
        {
            f[i] = 1;
            for(int j = i + i; j < 1000005; j += i)
                f[j]++;
        }
    }
    for(int i = 2; i < 1000005; i++)
    {
        memcpy(num[i], num[i - 1], sizeof num[i - 1]);
        num[i][f[i]]++;
    }
}
int main()
{
    init();
    int T;
    while(~scanf("%d", &T))
    {
        while(T--)
        {
            int l, r;
            scanf("%d%d", &l, &r);
            int a[8] = {0};
            for(int i = 1; i < 8; i++)
                a[i] = num[r][i] - num[l - 1][i];
            int ans = 1;
            for(int i = 7; i > 0; i--)
                if(a[i] > 1)
            {
                ans = i;
                break;
            }
            if(a[4] && a[2])
                ans = max(ans, 2);
            if(a[6] && a[3])
                ans = max(ans, 3);
            printf("%d\n", ans);
        }
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值