[数学]多校联合第三场 hdu5317 RGCDQ

Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know

maxGCD(F(i),F(j)) (L≤i<j≤R)

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000

Output
For each query,output the answer in a single line.
See the sample for more details.

Sample Input
2
2 3
3 5

Sample Output
1
1

题目大意:定于函数F(x)为x分解成质因数乘积中质因数的种类个数,对于给定的区间[l,r]求出maxGCD(F[i],f[j]) (l<=i<=j<=r)的值。

解题思路:用筛法预处理出1000000的F(x),可以发现,2*3*5*7*11*13*17*19 =9699690 > 1000000,所以F的值在10^6范围内不会大于7。求GCD时,无非就是求这几个数的组合。那么GCD的结果无非就是1,2,3,4,5,6,7.如果我们知道区间[l,r]内,每个F[i] = j 的数量有多少,就很容易求出最大的GCD了。
设num[i]为L~R中含有F[x] = i 的个数,
那么如果num[i] >=2 结果就是i,
如果num[i] 存在,且 i的倍数也存在,则结果也是i
尽量把答案往更大的方向去取即可。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;

const int MAXN = 1000005;
int F[MAXN];
int sum[MAXN][9];
bool used[MAXN];
void getprime()
{   //筛法求所有F[i]的值
    memset(F,0,sizeof F);
    memset(sum,0,sizeof sum);
    memset(used,0,sizeof used);
    for(int i = 2;i<MAXN;i++)
    {
        if (!used[i])
        {
            for(int j = i;j<MAXN;j+=i)
            {
                F[j]++;   //预处理了F表
                used[j] = true;
            }
        }
    }
    //sum[i][j] 表示2~i内 F[x] = j 的个数
    for(int i =2;i<MAXN;i++)
    {
        for(int j = 1;j<=8;j++)
        {
            sum[i][j] = sum[i-1][j];
            if (j==F[i])
                sum[i][j]++;
        }
    }
}


int main()
{

    getprime();
    int num[9]; //num[i]为L~R中含有f[x]=i的个数
    int T;
    //freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--)
    {
        int l,r;
        scanf("%d%d",&l,&r);
        memset(num,0,sizeof num);
        for(int i=1 ;i<9;i++)
        {
            num[i] = sum[r][i] - sum[l-1][i];
        }
        int ans = 1;

        for(int i = 2; i <= 8; i++)
        {
            if(num[i]==0)
                continue;
            if (num[i]>=2)
                ans = i;
            for(int j = 2; i*j < 8;j++)
                if (num[i*j]) ans = i;
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值