2015多校联合第五场 hdu5349 MZL's simple problem 优先队列

Problem Description
A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
 

Input
The first line contains a number  N  ( N106 ),representing the number of operations.
Next  N  line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than  109 .
 

Output
For each operation 3,output a line representing the answer.
 

Sample Input
  
  
6 1 2 1 3 3 1 3 1 4 3
 

Sample Output
  
  
3 4
 


好像这个题当时是做错了一直被我遗弃到现在 >_< 刚刚看了一遍WA代码 发现自己错在把优先队列的优先级弄错了T^T  top是最大的!top是最大的!top是最大的重要的事情说三遍!他说删最小的 查询最大的 模拟一下就好啦 

#include <iostream>
#include<cstdio>
#include<queue>
using namespace std;

int n,a,b,sum;
int main()
{
    while(~scanf("%d",&n))
    {
        priority_queue<int>que;
        sum=0;
        while(n--)
        {
            scanf("%d",&a);
            if(a==1)
            {
                scanf("%d",&b);
                que.push(b);
                sum++;
            }
            else if(a==2)
            {
                if(sum)
                sum--;
            }
            else if(a==3)
            {
                if(sum)
                printf("%d\n",que.top());
                else printf("0\n");
            }
            if(sum==0)
            {
                while(!que.empty()) que.pop();
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值