HDU 5349 MZL's simple problem(优先队列)

MZL's simple problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 776    Accepted Submission(s): 375


Problem Description
A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
 

Input
The first line contains a number  N  ( N106 ),representing the number of operations.
Next  N  line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than  109 .
 

Output
For each operation 3,output a line representing the answer.
 

Sample Input
  
  
6 1 2 1 3 3 1 3 1 4 3
 

Sample Output
  
  
3 4
 

Source
 






#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>
#include<math.h>
#include<queue>
#include<stack>
#include<map>
#define INF 0x3f3f3f3f
#define eps 1e-6

using namespace std;

priority_queue<int, vector<int>, greater<int> > q;///从小到大排列

int n;
int main()
{
    while(scanf("%d",&n)!=EOF)
    {

        while(!q.empty())
        {
            q.pop();
        }
        int x,y;
        int flag  = 0;
        int maxx;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            if(x == 1)
            {
                scanf("%d",&y);
                if(flag == 0)
                {
                    flag = 1;
                    maxx = y;
                }
                if(maxx < y)
                {
                    maxx = y;
                }
                q.push(y);
            }
            else if(x == 2)
            {
                if(q.size() > 0)
                {
                    int tt = q.top();
                    while(!q.empty() && q.top() == tt)
                    {
                        q.pop();
                    }
                }
                if(q.size() <= 0)
                {
                    flag = 0;
                }
            }
            else
            {
                if(q.size() > 0)
                {
                    printf("%d\n",maxx);
                }
                else
                {
                    printf("0\n");
                }
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值