2015多校联合第六场 hdu5373 The shortest problem 水

Problem Description
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
 

Input
Multiple input.
We have two integer n (0<=n<= 104  ) , t(0<=t<= 105 ) in each row.
When n==-1 and t==-1 mean the end of input.
 

Output
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.
 

Sample Input
  
  
35 2 35 1 -1 -1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 


第一次做 把每一位存到数组中 逐次往前挪 华丽丽的超时了 看标程 发现可以在源数字的基础上只操作数字 好了 用log10()又超时了orz 

得 照着标称做吧 改了一上午加一晚上一直WA 把变量名都换过去了 还不对 开头特判0写成1 一直没看出来!!!长点心吧

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
  //  freopen("cin.txt","r",stdin);
    int n,m,k,l,cas=1;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1) break;
       // printf("n=%d t=%d\n",n,t);
        if(m==0)
        {

            if(n%11==0) printf("Case #%d: Yes\n",cas++);
            else printf("Case #%d: No\n",cas++);
            continue;
        }
        k=n;
        l=0;
        while(k>0)
        {
            l+=k%10;
            k/=10;
        }
        while(m--)
        {
            k=l;
            while(k>0)
            {
                k/=10;
                n*=10;

            }
            n=(n+l)%11;
            k=l;
            while(k>0)
            {
                l+=(k%10);
                k/=10;
            }
        }

      //  printf("%d   ",n);
         if(n==0) printf("Case #%d: Yes\n",cas++);
        else  printf("Case #%d: No\n",cas++);

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值