HDU 5373 The shortest problem

The shortest problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 167    Accepted Submission(s): 85


Problem Description
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
 

Input
Multiple input.
We have two integer n (0<=n<= 104  ) , t(0<=t<= 105 ) in each row.
When n==-1 and t==-1 mean the end of input.
 

Output
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.
 

Sample Input
  
  
35 2 35 1 -1 -1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Source
 

Recommend
wange2014


题意:每次将原数各个位相加,然后防在后面,问经历t次之后能不能被11整除。

判断能不能被11整除只用看偶数位全部相加,奇数位全部相加,两个数的差能不能被11整除。

代码:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
int cnt;
int ans;
int sum;
void slove(int x)
{
	if(x >= 10) slove(x/10);
	if(cnt % 2)
	{
		ans += x % 10;
	}
	else
	{
		ans -= x % 10;
	}
	sum += x % 10;
	cnt++;
	return;
}
int main()
{
	int n, t;
	int cas = 0;
	while(~scanf("%d%d", &n, &t))
	{
		if(n==-1 && t==-1) break;
		ans = 0;
		cnt = 0;
		sum = 0;
		slove(n);
		ans %= 11;
		while(t--)
		{
			slove(sum);
			ans %= 11;
		}
		printf("Case #%d: ",++cas);
		
		if(ans)
		{
			printf("No\n");
		}
		else	printf("Yes\n");
		
	}
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值