poj3093Margaritas on the River Walk【01背包计算方法数】

Description

One of the more popular activities in San Antonio is to enjoy margaritas in the park along the river know as the River Walk. Margaritas may be purchased at many establishments along the River Walk from fancy hotels to Joe’s Taco and Margarita stand. (The problem is not to find out how Joe got a liquor license. That involves Texas politics and thus is much too difficult for an ACM contest problem.) The prices of the margaritas vary depending on the amount and quality of the ingredients and the ambience of the establishment. You have allocated a certain amount of money to sampling different margaritas.

Given the price of a single margarita (including applicable taxes and gratuities) at each of the various establishments and the amount allocated to sampling the margaritas, find out how many different maximal combinations, choosing at most one margarita from each establishment, you can purchase. A valid combination must have a total price no more than the allocated amount and the unused amount (allocated amount – total price) must be less than the price of any establishment that was not selected. (Otherwise you could add that establishment to the combination.)

For example, suppose you have $25 to spend and the prices (whole dollar amounts) are:

VendorABCDHJ
Price8987165

Then possible combinations (with their prices) are:

ABC(25), ABD(24), ABJ(22), ACD(23), ACJ(21), ADJ( 20), AH(24), BCD(24), BCJ(22), BDJ(21), BH(25), CDJ(20), CH(24), DH(23) and HJ(21).

Thus the total number of combinations is 15.

Input

The input begins with a line containing an integer value specifying the number of datasets that follow, N (1 ≤ N ≤ 1000). Each dataset starts with a line containing two integer values V and D representing the number of vendors (1 ≤ V ≤ 30) and the dollar amount to spend (1 ≤ D ≤ 1000) respectively. The two values will be separated by one or more spaces. The remainder of each dataset consists of one or more lines, each containing one or more integer values representing the cost of a margarita for each vendor. There will be a total of V cost values specified. The cost of a margarita is always at least one (1). Input values will be chosen so the result will fit in a 32 bit unsigned integer.

Output

For each problem instance, the output will be a single line containing the dataset number, followed by a single space and then the number of combinations for that problem instance.

Sample Input

2
6 25
8 9 8 7 16 5
30 250
1 2 3 4 5 6 7 8 9 10 11
12 13 14 15 16 17 18 19 20
21 22 23 24 25 26 27 28 29 30

Sample Output

1 15
2 16509438

Hint

Note: Some solution methods for this problem may be exponential in the number of vendors. For these methods, the time limit may be exceeded on problem instances with a large number of vendors such as the second example below.

Source


题意:背包限制“unused amount (allocated amount – total price) must be less than the price of any establishment that was not selected”之前理解一直纠结于要如何保证尽量装满,并没有深刻领悟到这句话的含义==——是剩下的钱数不能大于没买的物品的最小值,然后

之前做过一个也是涉及到方法数的背包

hdu2639bone collector II【第K优解】

然后思维就一直陷到可能要加一位表示方法数,然而这个题,不可以困在“遍历各个方法的值存储在数组里,然后维护第k大的”的思路,毕竟之前的题重复的算同一种orz

考虑那句关键的要求,那么需要遍历时候满足cost小于当前值的全部放入背包中!!我们存入cost数组后,从小到大排序。设定一个变量c,最开始为背包容量-物品总容量,c>=0,那么至少会有一种全选的情况。再说那几种循环:c每次加上了当前物品的花费,c>0才可以把这种情况的方案数加入总数量中,但是其他时候也得递推相加~

/************
poj3093
2016.3.13
696K	0MS	G++	794B
*************/
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[1000],t,n,m,c,ans,cost[100];
int main()
{
    //freopen("cin.txt","r",stdin);
    scanf("%d",&t);
    int cs=1;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        c=m;
        for(int i=1;i<=n;i++)scanf("%d",&cost[i]),c-=cost[i];
        sort(cost+1,cost+1+n);
        ans=(c>=0);
        if(cost[1]<=m)
        for(int i=n;i>=1;i--)
        {
            c=c+cost[i];
            if(c>=0)
                for(int j=max(0,c-cost[i]+1);j<=c;j++) ans+=dp[j];
            for(int j=m;j>=cost[i];j--) dp[j]+=dp[j-cost[i]];
        }
        printf("%d %d\n",cs++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值