hdu5188zhx and contest [01背包至少li才能。。。]

Description

As one of the most powerful brushes in the world, zhx usually takes part in all kinds of contests.
One day, zhx takes part in an contest. He found the contest very easy for him.
There are $n$ problems in the contest. He knows that he can solve the $i^{th}$ problem in $t_i$ units of time and he can get $v_i$ points.
As he is too powerful, the administrator is watching him. If he finishes the $i^{th}$ problem before time $l_i$, he will be considered to cheat.
zhx doesn't really want to solve all these boring problems. He only wants to get no less than $w$ points. You are supposed to tell him the minimal time he needs to spend while not being considered to cheat, or he is not able to get enough points.
Note that zhx can solve only one problem at the same time. And if he starts, he would keep working on it until it is solved. And then he submits his code in no time.
 

Input

Multiply test cases(less than $50$). Seek $EOF$ as the end of the file.
For each test, there are two integers $n$ and $w$ separated by a space. ($1 \leq n \leq 30$, $0 \leq w \leq {10}^{9}$)
Then come n lines which contain three integers $t_i, v_i, l_i$. ($1 \leq t_i,l_i \leq {10}^{5}, 1 \leq v_i \leq {10}^{9}$)
 

Output

For each test case, output a single line indicating the answer. If zhx is able to get enough points, output the minimal time it takes. Otherwise, output a single line saying "zhx is naive!" (Do not output quotation marks).
 

Sample Input

    
    
1 3 1 4 7 3 6 4 1 8 6 8 10 1 5 2 2 7 10 4 1 10 2 3
 

Sample Output

  
  
7 8 zhx is naive!

本题(bc)和这个题

hdu3466Proud Merchants【至少需要Qi才能买Pi】

(这是2010多校)

一样。多的就是优化上限TLE了两发==

#include<stdio.h>
    #include<algorithm>
    #include<iostream>
    #include<cstring>
    using namespace std;
    const int MAXN=4000009;
    int dp[MAXN];
    struct Node
    {
        int p,q,v;
    }node[35];
    bool cmp(Node a,Node b)
    {
        return  (a.q-a.p)<(b.q-b.p);
    }
    int main()
    {
       // freopen("cin.txt","r",stdin);
        int n,w;
        int i,j;
        int p,q,v;
        while(scanf("%d%d",&n,&w)!=EOF)
        {
            memset(dp,0,sizeof(dp));
            int sum=0,up=0;
            for(i=0;i<n;i++)
            {
                scanf("%d%d%d",&node[i].p,&node[i].v,&node[i].q);
                sum+=node[i].p;
                up=max(up,node[i].q);
            }
            up=max(up,sum);
            sort(node,node+n,cmp);
            for(i=0;i<n;i++)
            {
                for(j=up;j>=node[i].p;j--)
                {
                    if(j>=node[i].q)
                      dp[j]=max(dp[j],dp[j-node[i].p]+node[i].v);
                }
            }
            int ans=0;
            for(i=1;i<=up;i++)
              if(w<=dp[i])  {ans=i;break;}
            if(ans) printf("%d\n",ans);
            else puts("zhx is naive!");
        }
        return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值