hdoj zhx and contest 5188 (01背包)

zhx and contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 701    Accepted Submission(s): 253


Problem Description
As one of the most powerful brushes in the world, zhx usually takes part in all kinds of contests.
One day, zhx takes part in an contest. He found the contest very easy for him.
There are n problems in the contest. He knows that he can solve the ith problem in ti units of time and he can get vi points.
As he is too powerful, the administrator is watching him. If he finishes the ith problem before time li , he will be considered to cheat.
zhx doesn't really want to solve all these boring problems. He only wants to get no less than w points. You are supposed to tell him the minimal time he needs to spend while not being considered to cheat, or he is not able to get enough points.
Note that zhx can solve only one problem at the same time. And if he starts, he would keep working on it until it is solved. And then he submits his code in no time.

Input
Multiply test cases(less than 50 ). Seek EOF as the end of the file.
For each test, there are two integers n and w separated by a space. ( 1n30 , 0w109 )
Then come n lines which contain three integers ti,vi,li . ( 1ti,li105,1vi109 )

Output
For each test case, output a single line indicating the answer. If zhx is able to get enough points, output the minimal time it takes. Otherwise, output a single line saying "zhx is naive!" (Do not output quotation marks).

Sample Input
  
  
1 3 1 4 7 3 6 4 1 8 6 8 10 1 5 2 2 7 10 4 1 10 2 3

Sample Output
  
  
7 8 zhx is naive!
/* 题意: 给你两个数,n,w,n表示总共有n道题,w表示目标分数,问达到目标分数的最少时间。 接着是n行每行三个数,t,v,l.t表示做这道题要花费t时刻,          v表示这道题的分数为v,          l表示在l时刻才能真正算你完成了这道题(故意刁难。。) 思路: 知道题意后,这道题就简单了,就是一个稍微转换一下的01背包。。 */
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define ll long long
#define N 100010
using namespace std;
struct zz
{
	int t;
	int v;
	int l;
}q[35];
int dp[N];
int cmp(zz a,zz b)
{
	return a.l-a.t<b.l-b.t;
}
int main()
{
	int n,w;
	int i,j;
	while(scanf("%d%d",&n,&w)!=EOF)
	{
		int sum=0;
		int flag=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&q[i].t,&q[i].v,&q[i].l);
			sum+=q[i].v;
		}
		if(sum<w)
		{
			printf("zhx is naive!\n");
			continue;
		}
		sort(q,q+n,cmp);
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
		{
			for(j=N;j>=max(q[i].l,q[i].t);j--)
			{
				dp[j]=max(dp[j],dp[j-q[i].t]+q[i].v);
			}
		}
		for(i=0;;i++)
		{
			if(dp[i]>=w)
			{
				flag=1;
				break;
			}
		}
		if(flag)
			printf("%d\n",i);
		else
			printf("zhx is naive!\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值