hdu5813Elegant Construction【构造 2016多校联合第七场】

Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it's your showtime!
 

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.
 

Output
For each test case, output "Case #X: Y" in a line (without quotes), where X is the case number starting from 1, and Y is "Yes" if you can construct successfully or "No" if it's impossible to reach the requirements.

If Y is "Yes", output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
 

Sample Input
  
  
3 3 2 1 0 2 1 1 4 3 1 1 0
 

Sample Output
  
  
Case #1: Yes 2 1 2 2 3 Case #2: No Case #3: Yes 4 1 2 1 3 2 4 3 4
 

Author
SYSU
 

Source
 

已知n个点,要求添加任意有向边(没有重边和环)使得每个点能且只能到达ai个点(不包括自己),输出边

一看就乱搞啊,队友开始想到的是要更新每一个可以到达的点数,写的时候就卡在了怎样才能除去加重的那些点的点数这个问题上。一看题解恍然大悟。

既然是要连点,人家也没说非得连最少的边数啊,只要点数凑够了就好啦。题解中的做法是连接比这个点ai值小(和等于)的所有点,这么看来,如果ai值比这个点的序号大于(和等于),那么就只能输出no

可是有这样一个问题:我这一步要连得那些点中有些点是可能到达不止一个点的,会不会存在,我连了ai个点,但是总共可以到达的点数超过ai个呢?看这三组数据:

3
5
0 0 1 1 2
Case #1: Yes
4
3 1
4 1
5 1
5 2
6
0 0 1 1 2 2
Case #2: Yes
6
3 1
4 1
5 1
5 2
6 1
6 2
5
0 1 1 2 2
Case #3: Yes
6
2 1
3 1
4 1
4 2
5 1
5 2

如果返回的是这样的连边方式,我们就不用担心上文的错误了是不是?怎么做的到的呢?每次连边都从最小值对应点开始连边,那么,这个图只会长成一棵树,并不会出现下面分叉的情况,我们并没有必要非得纠结于怎样去连最少的边数呢

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int pos,val;
}num[1005];
bool cmp(node x,node y)
{
    return x.val<y.val;
}
int main()
{
   // freopen("cin.txt","r",stdin);
    int t,n,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i].val);
            num[i].pos=i;
        }
        sort(num+1,num+1+n,cmp);
        bool exi=1;
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(num[i].val>=i)exi=0;
            ans+=num[i].val;
        }
        printf("Case #%d: ",cas++);
        if(exi)printf("Yes\n");
        else {printf("No\n");continue;}
        printf("%d\n",ans);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=num[i].val;j++)
                printf("%d %d\n",num[i].pos,num[j].pos);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值