弱校联萌十一大决战之强力热身E Rectangle初中组合数学

题目啊 ~~

frog has a piece of paper divided into \(n\) rows and \(m\) columns. Today, she would like to draw a rectangle whose perimeter is not greater than \(k\).
 
 
There are \(8\) (out of \(9\)) ways when \(n = m = 2, k = 6\)
 
Find the number of ways of drawing.

Input

The input consists of multiple tests. For each test:
 
The first line contains \(3\) integer \(n, m, k\) (\(1 \leq n, m \leq 5 \cdot 10^4, 0 \leq k \leq 10^9\)).

Output

For each test, write \(1\) integer which denotes the number of ways of drawing.

Sample Input

2 2 6
1 1 0
50000 50000 1000000000

Sample Output

8
0
1562562500625000000

智商是硬伤→_→这题居然从一开始就想歪了只是取两个点而已嘛~然后又是有范围的 那么一定不是O(n^3)的算法==

假设长度固定为i,那么满足周长的条件下最宽宽度分为两种情况1、>m 2、0~m之间的

对于情况一 很显然宽度的边上能够取得的点是C(m,2)个

情况二就比较复杂啦 可取得的情况 从(m-1+1)、(m-2+1)到(m-(k/2)+i-1)都可以 对这组式子求和 得

[(k/2-i)*m-(k/2-i+1)/2*(k/2-i)+(k/2-i)]

#include <iostream>
#include<cstdio>
using namespace std;
long long n,m,k,ans;
int main()
{
    while(~scanf("%lld%lld%lld",&n,&m,&k))
    {
        ans=0;
        for(int i=1;i<=n;i++)
        {
            if(k/2-i<=m&&k/2-i>=0)
            {
                ans+=(n-i+1)*(2*m-k/2+i+1)*(k/2-i)/2;
            }
            else if(k/2-i>m)
                ans+=(n-i+1)*(1+m)*m/2;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值