PIGS
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 20091 | Accepted: 9199 |
Description
Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs.
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold.
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses.
An unlimited number of pigs can be placed in every pig-house.
Write a program that will find the maximum number of pigs that he can sell on that day.
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold.
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses.
An unlimited number of pigs can be placed in every pig-house.
Write a program that will find the maximum number of pigs that he can sell on that day.
Input
The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N.
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000.
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line):
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000.
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line):
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.
Output
The first and only line of the output should contain the number of sold pigs.
Sample Input
3 3 3 1 10 2 1 2 2 2 1 3 3 1 2 6
Sample Output
7
Source
引用黄学长的题解——
把每个卖猪的人作为点,当前来买猪的人如果先前买猪的人打开相同的猪圈,则先前那个人可以把所有能开的猪圈里的猪留给它,也就是在他们之间连一条无穷大的边,然后,如果是第一个开某个猪圈的人,就在源点与某人直接连上容量为猪圈中猪的数量的边,每个人与汇连上一条容量为它想买猪的数量的边,此时求最大流,最大流即答案
/**************
poj1149
2016.8.20
3776K 16MS C++ 2186B
**************/
#include <stdio.h>
#include<cstring>
#include <iostream>
#include<vector>
#include<algorithm>
#include<cstring>
using namespace std;
const int oo=0x3f3f3f3f;
const int mm=900000;
const int mn=900000;
int node ,scr,dest,edge;
int ver[mm],flow[mm],Next[mm];
int head[mn],work[mn],dis[mn],q[mn];
void prepare(int _node,int _scr,int _dest)
{
node=_node,scr=_scr,dest=_dest;
for(int i=0; i<node; ++i)
head[i]=-1;
edge=0;
}
void addedge(int u,int v,int c)
{
ver[edge]=v,flow[edge]=c,Next[edge]=head[u],head[u]=edge++;
ver[edge]=u,flow[edge]=0,Next[edge]=head[v],head[v]=edge++;
}
bool Dinic_bfs()
{
int i,u,v,l,r=0;
for(i=0; i<node; i++)
dis[i]=-1;
dis[q[r++]=scr]=0;
for(l=0; l<r; ++l)
{
for(i=head[u=q[l]]; i>=0; i=Next[i])
{
if(flow[i]&&dis[v=ver[i]]<0)
{
dis[q[r++]=v]=dis[u]+1;
if(v==dest)
return 1;
}
}
}
return 0;
}
int Dinic_dfs(int u,int exp)
{
if(u==dest)
return exp;
for(int &i=work[u],v,tmp; i>=0; i=Next[i])
if(flow[i]&&dis[v=ver[i]]==dis[u]+1&&(tmp=Dinic_dfs(v,min(exp,flow[i])))>0)
{
flow[i]-=tmp;
flow[i^1]+=tmp;
return tmp;
}
return 0;
}
int Dinic_flow()
{
int i,ret=0,delta;
while(Dinic_bfs())
{
for(i=0; i<node; i++)
work[i]=head[i];
while(delta=Dinic_dfs(scr,oo))
ret+=delta;
}
return ret;
}
int n,m;
int last[mm],num[mm];
int main()
{
// freopen("cin.txt","r",stdin);
while(~scanf("%d%d",&m,&n))
{
prepare(n+2,0,n+1);
memset(last,0,sizeof(last));
for(int i=1;i<=m;i++)scanf("%d",&num[i]);
for(int i=1;i<=n;i++)
{
int a,x,b;
scanf("%d",&a);
while(a--)
{
scanf("%d",&x);
if(!last[x])addedge(0,i,num[x]);
else addedge(last[x],i,oo);
last[x]=i;
}
scanf("%d",&b);
addedge(i,n+1,b);
}
printf("%d\n",Dinic_flow());
}
return 0;
}