C#程序设计练习题十七: 问题 E: C#统计字符出现的个数

题目描述

编写一个实例方法getCountChar方法。该方法参数有两个,第一个参数可以是字符串s,第二个参数为字符c,方法返回值为第二个参数在第一个参数中出现次数。例如,CountChar("6221982",'2')返回值为3。
部分程序代码已经给出。
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string str = Console.ReadLine();     
            char ch = (char) Console.Read();
            Program pro = new Program();
            Console.WriteLine(pro.getCountChar(str,ch));

            //Console.ReadKey();
        }
        public int getCountChar(String s,char c){
        //


        在此处填写代码


        //
        }
    }
}

 

提交时,请提交整个题目!!!

输入

一个字符串s,一个字符c

输出

该字符c在字符串s中的出现次数

样例输入

copy

6221982
2

样例输出

3
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string str = Console.ReadLine();
            char ch = (char)Console.Read();
            Program pro = new Program();
            Console.WriteLine(pro.getCountChar(str, ch));

            Console.ReadKey();
        }
        public int getCountChar(String s, char c){
        //
            int num = 0;
            for (int i = 0; i < s.Length; i++)
            {
                if (s[i] == c)
                    num++;
            }
            return num;

        


        //
        }
    }
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值