删除单链表偶数节点

删除单链表偶数节点

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

struct ListNode {
    int data;
    struct ListNode *next;
};

函数接口定义:

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );

函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
     struct ListNode *p = head;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *head;

    head = createlist();
    head = deleteeven(head);
    printlist(head);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 2 2 3 4 5 6 7 -1

输出样例:

1 3 5 7 

代码:

struct ListNode *createlist()
{
	struct ListNode *head,*p,*q;
	
	p=(struct ListNode *)malloc(sizeof(struct ListNode));
	head=(struct ListNode *)malloc(sizeof(struct ListNode));
	head->next=NULL;
	scanf("%d",&p->data);
	while(p->data!=-1)
	{
		if(head->next==NULL)
			head->next=p;
		else
			q->next=p;
		q=p;
		p=(struct ListNode *)malloc(sizeof(struct ListNode));
		scanf("%d",&p->data);
	}
	q->next=NULL;
	return head;
}


struct ListNode *deleteeven( struct ListNode *head )
{
	struct ListNode *q,*p;
	
	p=head;
	q=head->next;
	
	while(q!=NULL)
	{
		if((q->data)%2==0)
			p->next=q->next;
		
		else 
			p=p->next;
		q=q->next;
	}
	return head->next;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值