0-1背包问题,poj 3624 Charm Bracelet动态规划-解题报告,增加最优路径构建


1)0-1背包问题和 零碎背包问题是不同的,前者只能用动态规划来做, 后者可以用贪心算法。

2)动态规划的核心是 “有多个重叠子问题”,“自底向上”解决问题。

3) 0-1背包问题 ,W为最大重量,n为物体个数,求最大的价值Value,可在O(nW)的时间复杂度内解算出来。

Language:Default

Charm Bracelet

Time Limit: 1000MS
Memory Limit: 65536K

Total Submissions: 10014
Accepted: 4498

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from theN (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factorDi (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more thanM (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December Silver

#include <stdio.h>
int N,M;
int W[3410],D[3410];
int f[12882];
int rout[12882]; //寻根,帮助重建 
int main()
{
   scanf("%d%d",&N,&M);
   for(int i=1;i<=N;i++)
   {
       scanf("%d%d",&W[i],&D[i]);
   }  
   for(int i=1;i<=M;i++)
   { 
      f[i]=0;
      rout[i]=-1;
  }    
   for(int i=1;i<=N;i++)
   //注意不是从W[i]到M,而是从M到W[i],因为这次是基于上次的基础(后者),而不是重复算两次当下(前者) 
      for(int j=M;j>=W[i];j--)
      {
          if(f[j-W[i]] +D[i]>f[j])
          {
                    f[j]=f[j-W[i]]+D[i];
                    rout[j]=W[i];          
          }    
      }    
   int ma=-1;
   int pos=-1;
   for(int i=1;i<=M;i++)
      if(f[i]>ma)
      {
       ma=f[i];
       pos=i;
      }   
   
   printf("%d\n",ma);
  int j=pos;
   while(rout[j]!=-1 && j>0)
   {
       printf("%d\n",rout[j]);
       j=j-rout[j];
   }   
   
    scanf("%d",&N); 
   return 0;
}    

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值