本题要求编写程序,将给定n×n方阵中的每个元素循环向右移m个位置,即将第0、1、⋯、n−1列变换为第n−m、n−m+1、⋯、n−1、0、1、⋯、n−m−1列。
输入格式:
输入第一行给出两个正整数m和n(1≤n≤6)。接下来一共n行,每行n个整数,表示一个n阶的方阵。
输出格式:
按照输入格式输出移动后的方阵:即输出n行,每行n个整数,每个整数后输出一个空格。
输入样例:
2 3
1 2 3
4 5 6
7 8 9
输出样例:
2 3 1
5 6 4
8 9 7
#include<stdio.h>
#include<ctype.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
int main()
{
int n,m;
scanf("%d%d",&n,&m);
int s[m][m];
n%=m;
for(int i=0;i<m;i++){
for(int j=0;j<m;j++){
scanf("%d",&s[i][j]);
}
}
for(int i=0;i<m;i++){
for(int j=m-n;j<m;j++){
printf("%d ",s[i][j]);
}
for(int j=0;j<m-n;j++){
printf("%d ",s[i][j]);
}
printf("\n");
}
}