大数相加NYOJ103

NYOJ103
A+B Problem II
时间限制:3000 ms | 内存限制:65535 KB
难度:3

描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation.
样例输入

2
1 2
112233445566778899 998877665544332211

样例输出

Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include <stdio.h>
#include <string.h>
char a[1005];
char b[1005];
int c[1005];
int main()
{
    int T,t=0;
    scanf("%d",&T);
    getchar();
    while(T--)
    {
        memset(c,0,sizeof(c));
        scanf("%s%s",a,b);
        int la=strlen(a);
        int lb=strlen(b);
        int i,j,s,k=0,v=0;
        for(i=la-1,j=lb-1;;i--,j--)
        {
            if(i<0&&j<0)
                break; 
            if(i<0)
                s=(b[j]-'0')+v;
            else if(j<0)
                s=(a[i]-'0')+v;
            else
                s=(a[i]-'0')+(b[j]-'0')+v;
            c[k]=s%10;
            v=s/10; 
            if((i==0&&j<=0||i<=0&&j==0)&&v!=0)
                c[++k]=v;
            k++;
        }
        printf("Case %d:\n",++t);
        printf("%s + %s = ",a,b);
        for(i=k-1;i>=0;i--)
            printf("%d",c[i]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值