1054. The Dominant Color (20)-PAT

1054. The Dominant Color (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
推荐指数:※※
来源:http://pat.zju.edu.cn/contests/pat-a-practise/1054
这道题目想到了方法就很简单,正好,我看过编程之美2.3寻找发帖”水王“,这一题只是壳子不同,输入的时候不相同的互相抵消,多余一半的肯定不会被抵消完的。通俗的来说:有一个椅子,有很多teams都想坐上去,每个team各个队员的战斗力是一样的(不同team队员遇到1:1消失),同样的成员都会在椅子上。现在所有人混在一起,排成一大队一个一个的去抢椅子,如果有一个team的队员大于总队员一半,1:1战斗完后剩下的一定是他的队员。
不然用map也可以。
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int m,n;
	scanf("%d%d",&m,&n);
	int i,j,candidate,ntimes=0;
	for(i=0;i<m;i++){
		for(j=0;j<n;j++)
		{
			int color;
			scanf("%d",&color);
			if(ntimes==0){
				candidate=color;
				ntimes++;
			}
			else
			{
				if(candidate==color)
					ntimes++;
				else
					ntimes--;
			}
		}
	}
	printf("%d\n",candidate);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值