Box of Bricks

Problem Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I\'ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.
 
Output

 For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.

Sample Input

6
5 2 4 1 7 5
0

Sample Output

Set #1
The minimum number of moves is 5.

题目大意:给你N堆砖块的高度,为了使N堆砖块的高度已知,需要把高的堆上的

砖块移到低的堆上,问最少需要移多少块砖。

思路:计算出总共的砖块数,在求出N堆砖的平均高度(即需要达到的最终高度),把

高的堆上的砖移到不足平均高度的堆上。应该计算出所有不足高度的堆上总共差多少

砖达到高度,即为结果。

// Box of Bricks 正确的
/*算出总共的砖块数,在求出N堆砖的平均高度(即需要达到的最终高度),把

高的堆上的砖移到不足平均高度的堆上。应该计算出所有不足高度的堆上总共差多少

砖达到高度,即为结果。
*/
# include<stdio.h>
int main()
{
	int t=1,n,i,sum,min;
	while(scanf("%d",&n)!=EOF)
	{
		int hi[51]={0};
		if(n==0) break;
		for(sum=i=0;i<n;i++)
		{
			scanf("%d",&hi[i]);
			sum+=hi[i];
		}
		sum/=n;
		for(min=i=0;i<n;i++)
		{
			if(hi[i]>sum)
			min+=(hi[i]-sum);
			else  
			min+=(sum-hi[i]);
		}
			printf("Set #%d\n",t);
			t++;
			printf("The minimum number of moves is %d.\n\n",min/2);
		}
	return 0; 
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值