【C语言做题系列】Box of Bricks

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. Look, I've built a wall!'', he tells his older sister Alice.Nah, you should make all stacks the same height. Then you would have a real wall.’’, she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.
Output
For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.’’, where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.
Sample Input
6
5 2 4 1 7 5
0
Sample Output
Set #1
The minimum number of moves is 5.

题意:
给出一个整数n,需要输入n个数,每次只挪动(加减)单位1,从而使每个数变成这n个数的平均数,问需要做少需要多少次才能达到要求。
注意:
本题有两个注意点。
1、在最后的样例输出中需要输出这是第几组数据。
2、“Output a blank line after each set.”即 当输出最终答案“The minimum number of moves is 5.”后还需要两个换行。此为格式问题。
算法思想:
求出这n个数的平均数,然后找出比平均数大的数字,因为每次只能加减单位1,所以相减得到的,便是该数 需要 变化成 平均数 所需要的次数。
上代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=1e5+5;
int a[maxn];

int main()
{
    int n;
    int average;          //定义一个平均数
    int k;                //定义一个k来装每个数字与平均数的差
    int len =1;           //定义一个len 表示当前集合的编号
    while(scanf("%d", &n),n)       //当输入的n=0时,程序停止
    {

        int sum = 0;               //定义一个sum来装他们的和
        int num=0;               //定义一个num 来装最后的次数
        for(int i=1; i<=n; i++)
        {
            scanf("%d", &a[i]);
            sum+=a[i];             //输入并求和
        }
        average = sum/n;           //求平均数
        for(int i=1; i<=n; i++)
        {
            if(a[i]>average)       //判断
            {
                k=a[i]-average;    //相减
                num+=k;             //得结果
            }

        }
        printf("Set #%d\n", len);
        printf("The minimum number of moves is %d.\n\n", sum1);//此处输出需要两个换行
        len++;         //  编号递增
    }
    return 0;
}


心得:
有时候出错不一定是算法的问题,可能是输入输出的问题,检查的时候要从一而终,每个地方都不能放过。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值